Modded Mustang Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
648 Posts
Discussion Starter #1
1997 V6 Mustang is overheating. Was driving it home and it started to heat up , and then the hot air turned cold, has been doing that a little but only in the morning. (the air that is, 1st time overheating) need help quickly please!

Thanks
Bryan
 

·
Registered
Joined
·
135 Posts
my friend didn't have his overheating problem checked out, and he burnt up so much that he had to buy a new motor.
 

·
Registered
Joined
·
648 Posts
Discussion Starter #5
Yea i knew it was serious, just wanted to know what it might be, i knew it was proly the radiator just wating for it to cool down so i can check. Thanks for the quick response.
 

·
Registered
Joined
·
135 Posts
lol, when it got to hot, my friends spark plug got melted to his block.
 

·
Registered
Joined
·
648 Posts
Discussion Starter #8
alright will do man thanks for caring :) should know if im fine here in a min or two
 

·
Registered
Joined
·
1,409 Posts
Yeah I had the same problem. I took it to Ford and asked them to check the radiator. They told me that there was nothing wrong with my radiator but that my cylinder heads were ****ed. They wanted a stupid amount of money to figure out wether or not the engine needed to be replaced. This was a problem that I know was common on the '95 v6 so I took it to a better mechanic that I actually trust. He actually fixed the problem for less than half what Ford wanted to charge to not fix the problem. As he was fixing it the guy calls me and says BTW your radiator is busted. Ford told me that my radiator was fine. They even charged me to test the radiator and tell me it was fine. I knew damn well that it wasn't. It is what caused the cylinder heads to warp! The moral of the story...NEVER take your car to ford.
 

·
¡ʇsnq ɹo uʍop ǝpısdn
Joined
·
12,571 Posts
replace your thermostat you can get them for $6 at the parts store, and you can pick up some RTV and make your own gasket if they don't have any
 

·
Registered
Joined
·
648 Posts
Discussion Starter #12
ok i got it figured out it was just low on coolant lol i am an idiot lol. Thanks for the help guys!
 
1 - 16 of 16 Posts
Top