Modded Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Only 2 for now, so bear with me...

I have a recently purchased 2001 Mustang GT Bullitt with about 64k on it. When the engine is under 2k and I am giving it over 70% throttle or a decent incline comes up, the car seems to hiccup and buck a little. It's not there at 2k or higher, or when I am only touching the gas. Checked the spark plugs, they are new, fuel filter is new, and the MAF is fine. Any ideas??

Also, I need a new bumper, I found one on Partstrain.com for about 95.00. Is this a reputable site, and if it isn't, does anyone know of a good one that sells bumpers for about the same?

Thanks alot
 

·
Registered
Joined
·
428 Posts
your miss could be a bad coil on plug. i had 1 (possibly more) go bad on me and it did the same thing. and it did not trigger the CEL for the longest time. Finally I just replaced all 8 and fixed my problem. Just and idea for you to check out.
 

·
Registered
Joined
·
110 Posts
You may be in too low of a gear.
 

·
Registered
Joined
·
110 Posts
All you described was under 2k rpm's with 70% throttle on a decent incline....If you were in 5th gear going up hill under 2k rpms....It might hiccup or buck on you. It was just my .02. If that wasnt it then its prolly a COP.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #6
sorry if you misread, i said or on an incline, its not just a 5th gear issue, its 2-5th straight line or incline. I will be checking the COP. Doesn anyone know if partstrain.com is any good?
 
1 - 6 of 6 Posts
Top