Modded Mustang Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
482 Posts
Discussion Starter · #1 ·

·
Administrator
Joined
·
83,767 Posts
Probably because the cheap one looks like a ridiculously flimsy and cheap japanese knock-off item, and would probably last about a week before breaking.

You usually get what you pay for.
 

·
Registered
Joined
·
482 Posts
Discussion Starter · #3 ·
i agree but i have been on differnt threads on this site and several people are running the VVME setup and they seem to like them.. thats whats throwing me off...
 

·
Registered
Joined
·
1,427 Posts
People swear by VVME by i perfer HIDGUY.net thats where mine came from and they have great customer service and nice people to work with..........VVME is also made in CHina so the labor is pennies on the dollar.
 

·
Registered
Joined
·
646 Posts
i got the vvme HIDs i dont have any complaints but when i was choosing which ones to get the way I saw it was I spend 44 bucks and they are complete **** and im out 44 bucks big whoop .. i spend $200 and they are **** and im out 200 and really pissed off
 

·
May 08 ROTM
Joined
·
7,192 Posts
Running vvme's in the stang for 10 months, all is good. Happy enough I went ahead and used them in my Denali as well. The Denali hids are 400x better simply because of the oem projectors lighting tendencies.

I'd do them again in any other ride I might purchase. Been that happy.
 

·
Registered
Joined
·
482 Posts
Discussion Starter · #8 ·
so this is just a really good deal then lol
 

·
Registered
Joined
·
321 Posts
I got all my kits on ebay xenon fog and hid conversion great product no issues although some headlight conversion require a relay to the battery due to the inconsistency of electrical currents on the headlights only requiring 35w for HID power instead of the regular 55w halogen
 

·
Registered
Joined
·
318 Posts
Get a good kit (I have RetroSolutions and I love them). Yes, you do get what you pay for.
 

·
Premium Member
Joined
·
14,581 Posts
have had a vvme on my car for about 6 months now, no problems at all. they work great. the only thing that might get you is if a bulb goes out or a ballast and you have to ship it back to china. the kit is great though.
 

·
Registered
Joined
·
293 Posts
8 Months and no problems here with vvme's....I had them in a different car also for 2 years and no problems.

 

·
MM's Resident Muffler Shop
Joined
·
3,048 Posts

·
Registered
Joined
·
482 Posts
Discussion Starter · #17 ·
have had a vvme on my car for about 6 months now, no problems at all. they work great. the only thing that might get you is if a bulb goes out or a ballast and you have to ship it back to china. the kit is great though.
8 Months and no problems here with vvme's....I had them in a different car also for 2 years and no problems.

I have the VVME 35w on mine (hi/low), zero issues. :)


well according to these people your not really getting what you pay for. you are paying for somethings that most people would think would be **** and getting a quality product......
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top