Modded Mustang Forums banner

1 - 14 of 14 Posts

·
I Have A FLATULENT Butthole.
Joined
·
7,889 Posts
Discussion Starter #1
I'm not sure if this is just a mustang thing, a ford thing, or a mycarsucks thing, but my brights don't stay on when i pull back on the turn signal. I have to keep one hand on the lever so they stay on. I've noticed that if i pull it back with the car off, then start it they will stay on. But other than that i can't figure out how to get them to stay on, any help here fellas?
 

·
Premium Member
Joined
·
9,751 Posts
you push forward on the turn signal lever to turn on the highbeams, pulling it toward you is just to flash the highbeams
 
  • Like
Reactions: (Kohrs93)

·
I Have A FLATULENT Butthole.
Joined
·
7,889 Posts
Discussion Starter #3
You freakin serious lol? Wow I feel like a dumbass now. Why did ford design such a stupud system :mad
 

·
Premium Member
Joined
·
9,751 Posts
You freakin serious lol? Wow I feel like a dumbass now. Why did ford design such a stupud system :mad
don't sweat it bro, your not the first one to have trouble with this.
 

·
I Have A FLATULENT Butthole.
Joined
·
7,889 Posts
Discussion Starter #6
it isn't stupid, tons of other cars use this system too. you're probably used to the toggle type where you pull it towards yourself.
It is stupid to me, i've only ever used "normal" ones that you pull towards you :lol
 

·
Disturbin' The Peace
Joined
·
4,121 Posts
Don't feel bad, I was confused on this too when I got my 03. I was used to a 90 dodge truck, it had the "normal" high beam switch too.
 

·
Not a Rational Car Guy
Joined
·
38,186 Posts
:lmao
 

·
Registered
Joined
·
1,358 Posts
Wow.... :yourock
 
1 - 14 of 14 Posts
Top