Modded Mustang Forums banner

1 - 12 of 12 Posts

·
King of Clubhouse
Joined
·
5,277 Posts
Discussion Starter #1
Ok guys I got up to go to my enterview I was stoked (cause i need a job) and I get in my stang start it up and she didnt want to start (i think because its cold) then it starts but OMG all the lights came on for gas, oil, low coolant and im freakin so I turn it off right away

Check them all and they seem ok (does need some coolant possibly though I checked the bottle thing and I cant see any of it)

But then I remembered the gas light didnt work my fuel gauage doesnt work so I drove it because I HAD to, to get to the interview and guess what I didnt even get the F***IN job man this morning isnt good

Any advice about the stang think it might be something electrical or what

When you feel like giving up push harder right?
 

·
Registered
Joined
·
569 Posts
sounds like some kind of electrical issue ...you said you were having other electrical issues right?
 

·
King of Clubhouse
Joined
·
5,277 Posts
Discussion Starter #3
yeah my F***IN lights dont work my blinkers dont work OOOOO maybe its that multi functional thing right that controls the blinkers I heard they go out

I drove her but she seemed fine and if I cant see the coolant in the tube (you know where it says full when hot/cold) i cant really see it should I add some>?
 

·
Registered
Joined
·
90 Posts
when the cars cooled down open the radiator cap and check if theres some in there if its low add to it then fill the overflow to full cold thats were mines always at well i try to keep it there
 

·
Registered
Joined
·
2,111 Posts
So, with a full overflow tank cold.. what happens when the car overheats for some reason? Wheres the overheated coolant going to go? Take a moment to think about what "overflow" means, and why the tank is referred to as such.

Dont fill your overflow tank with the engine cold.
 

·
King of Clubhouse
Joined
·
5,277 Posts
Discussion Starter #6
question lol cant get my radiator cap off haha i lifted the thing that says lift and it says twist and pull off I twisted but it wont pull off and im afraid im gonna break it
 

·
Registered
Joined
·
4,781 Posts
push and twist. you probably didn't twist it off all the way.
 

·
King of Clubhouse
Joined
·
5,277 Posts
Discussion Starter #8
o ok

any one have any suggestions on the electrical problem (i know i cant spell lol) im getting a another job interview in the next two days and I need to know what you guys think will it be ok if I run her even though those lights are on? I checked the oil 4 times this morning to make sure and she was full Havnt checked radiator yet but long as those are good the motor will be ok right?
 

·
Registered
Joined
·
4,781 Posts
Sounds like an electrical issue. It would take a miracle to have problems with all those systems at the same time. Should be OK for a short drive, but get them fixed ASAP so you'll know when you are having a real problem.
 

·
King of Clubhouse
Joined
·
5,277 Posts
Discussion Starter #10
yeah I just have to find out whats causing it one step at a time I suppose suggestion on places to start??
 

·
Registered
Joined
·
698 Posts
Start with Autozone or Pep Boys. They will test your charging system for free and most likely steer you in the right direction.
 

·
Registered
Joined
·
371 Posts
dude get yourself a fuse test light and test all fuses with the ignition on, fuse box in interior, and fuse box under hood or fuseible links if your car is a 87 or 88

ive killed some nasty electrical issues with this $5 item
 
1 - 12 of 12 Posts
Top