Modded Mustang Forums banner

1 - 20 of 43 Posts

·
I'm cool..
Joined
·
2,277 Posts
Discussion Starter · #1 · (Edited)
So the mail man came today and brought me my HIDs. Well surprise surprise they came with no instructions... and the HIDs from DDM are different from MMRs HID that suck. I chose the 55w, 8000K, Dual beam, HID kit.

As promised.

Total time to figure it all out and install WITH OUT INSTRUCTIONS= ~2 hours.
With instructions= ~30 minutes
Difficulty= Easy

So for those who are stuck, maybe this will help.

First start by disconecting the battery


I decided to lay everything out on the floor and see how it all bolted up.




I actually removed the battery to have more room during the install. First thing was i removed the head light completly (Refer below if you dont know how to). This made things a lot easier!





(Yes i used old pictures because i didnt want to take pictures of the same thing twice)

After the head light was out I took out the light bulb and took the bottom, lets call it "shell case", and plugged it into the head light. The new lights are way longer. Almost twice as long as the MMR HID kit.



Take the rubber peices off, in this case the blue and clear peices. This will allow it to actually be locked in place by the back holder.



Next, after the shell is locked in, put the bulb in and lock it in. It should look like this. Use gloves for this process! NEVER EVER EVER TOUCH THE BULB WITH YOUR FINGERS! The oil on your hand will cause the bulb to pop.

 

·
I'm cool..
Joined
·
2,277 Posts
Discussion Starter · #2 ·
Plug the male and females up from the ballest to the lights. This part is plug and play. There really isnt an excuse for error. :eek:

I used the double sided tape to tape the ballest on to the side of the engine bay AWAY from anything too hot.



I hid all the wires between the batter and my head lights for a nice clean flush look. I used some zip ties to clean the engine bay better.



Next this part confused me for almost an hour. It came with only ONE BLUE PLUG! OUR CARS HAVE 2! I thought that they sent me the wrong one and then i decided to only hook it up. It was the only logical thing to do and it worked. Dont freak out... its not a mess up :mad::eek:

Put the battery back on, and properly hook up the ground and power wires.




Now your done!
 

·
Registered
Joined
·
5,175 Posts
Nice but where are the pics of how they actually look come on we need to see those haha. Just giving you a hard time nice write up by the way, but yeah let see them before and after pics. Also this is the DDM kit correct.
 

·
I'm cool..
Joined
·
2,277 Posts
Discussion Starter · #5 ·
... about the put a shirt coment... No. Its hot.

Well no before and after, but these are almost 2 times brighter.

Low




High


 

·
Registered
Joined
·
1,864 Posts
Nice job. I think you need to clean your engine bay. lol. How much was the kit?
 

·
Registered
Joined
·
5,175 Posts

·
I'm cool..
Joined
·
2,277 Posts
Discussion Starter · #9 ·
I do need to clean the engine bay... Kit cost me $105 dollars. Ill take some real photos with my camera. The Iphone doesnt do justice to what they really look like!
 

·
Registered
Joined
·
109 Posts
@gtracer
this hid kit still working good? any one bulb on one off issues?
also what bulb type u get the h4, h13, 9004, or 9007, dual beams? or does it matter?
edit nvm found a replacement guide said get 9007
 

·
I'm cool..
Joined
·
2,277 Posts
Discussion Starter · #11 ·
@gtracer
this hid kit still working good? any one bulb on one off issues?
also what bulb type u get the h4, h13, 9004, or 9007, dual beams? or does it matter?
edit nvm found a replacement guide said get 9007
Sorry for the late response. Yes get 9007. Also dual beams means high beams and low beams.
 

·
Registered
Joined
·
109 Posts
hey :D, well i installed my kit 55w dual beam 8000k.
have an issue tho :(
when i turn them on, they go bright then dim then gradually go bright ( 5 seconds)
figured that is normal.
But real problem is sometimes the passenger side doesn't come on. (fix it by turning lights off then on again)
do both urs come on 100% time? or u experience same issue ?
 

·
Premium Member
Joined
·
1,169 Posts
Bedojo, I have the same issue with mine, pass comes on the off. have to flick the lights back off and on for it to come on. not a reall uissue for me, but it does happen. when it warms up Im gonna swap the bulbs and see if the problem goes to the drivers side. I ordered a set of 55W balasts so once they get here (on the 5th) I will swp them in and see if the passenger side issue is still there.
 

·
Registered
Joined
·
220 Posts
I was thinking bout getting some for my car. do all them not work sometimes? then ya just got to turn them on and off? But there to hard at all to install r they?
 

·
Premium Member
Joined
·
1,169 Posts
Simple install. I replaced the Ballasts in mine with 55W ones and the issue i had with them not firing went away. Yay bad ballast... but now with my 55W 6000K D2S bulbs in retrofitted Acura TL projectors I'm LOVIN the light output. uber sharp cut off, nice blue color on it. great light output. maybe not go as far into it as I did, but I would definitely recommend them.
 

·
Banned
Joined
·
17,374 Posts
hey :D, well i installed my kit 55w dual beam 8000k.
have an issue tho :(
when i turn them on, they go bright then dim then gradually go bright ( 5 seconds)
figured that is normal.
But real problem is sometimes the passenger side doesn't come on. (fix it by turning lights off then on again)
do both urs come on 100% time? or u experience same issue ?
this is a problem with the dual beams...my dads 03 f-150 had the same issue when i put the dual beam kit in it....you can get a power adapter for about $20 online that keeps it from happening...think of the shutting off as a way for your car to not blow up a stock bulb...however the car doesnt' know you put a HID kit on so it doesn't know it can now handle the power...the adapter fools the car into thinking nothing it out of the ordinary with the power....here is a link to the one i used on his truck

Error Code Eliminator - 3 (PAIR): HID Kits, DEPO Lights, BMW Bumpers & Lighting - DDM Tuning

reps if this helped
 

·
Banned
Joined
·
7,007 Posts
Quick question, is the blue pretty noticeable in person on the 8k kits? Because in pictures it looks more white, but I've heard that cameras can't really capture the color very well
 

·
I'm cool..
Joined
·
2,277 Posts
Discussion Starter · #20 ·
hey :D, well i installed my kit 55w dual beam 8000k.
have an issue tho :(
when i turn them on, they go bright then dim then gradually go bright ( 5 seconds)
figured that is normal.
But real problem is sometimes the passenger side doesn't come on. (fix it by turning lights off then on again)
do both urs come on 100% time? or u experience same issue ?
All HIDs take time to warm up... Just how they work i guess... Mine too have problems when the passenger light chooses not to come on. I have to turn the car off and then the lights, then turn the car on and then the lights and it get rid of the problem. It gets on my nerves..

Quick question, is the blue pretty noticeable in person on the 8k kits? Because in pictures it looks more white, but I've heard that cameras can't really capture the color very well
With the 55w they aren't as noticeable compared to 35w BUT you can see the blue. Its more like a light blue if anything. Its a balance between white and blue. Hard to explain. Ill take a better picture with my HD2 later.
 
1 - 20 of 43 Posts
Top