Modded Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
575 Posts
Discussion Starter #1
k i have a problem i jsut installed my upr x pipe and now wen i start the car up u can feel like big thumps inside the car and wen i drive it smoke comes out i had a o/r mac h pipe before and it smells like sumtin burning under and wen i look the x pipe is shooting smoke off of it
 

·
Registered
Joined
·
575 Posts
Discussion Starter #3
nope not back firing sounds good the only thing that gets me scared is the car idles alil ruogher now with the upr x pipe and my slp lm2 and the smelll other than that eveything is good and now for some reason wen i go to plug in my xcal 2 it wont tunr on i need help
 

·
Registered
Joined
·
922 Posts
check to make sure your o2 plugs are not hanging too close to the pipe because if they are, they will melt and drip onto the pipes and it will smoke like a freaking freight train and stink too.
 

·
Registered
Joined
·
1,381 Posts
nope not back firing sounds good the only thing that gets me scared is the car idles alil ruogher now with the upr x pipe and my slp lm2 and the smelll other than that eveything is good and now for some reason wen i go to plug in my xcal 2 it wont tunr on i need help
its just the coating burning off this will happen for about a week with the funny smell it should be gone soon though.. after that the rich exhaust smell will always be there
 

·
Registered
Joined
·
575 Posts
Discussion Starter #6
k now shouyld my car idle alil more rough with the o/r x pipe then it did withg my o/r h pipe and y does smoke come out of my exhaust it never did it before i switched my o/r h pipe to the o/r x
 

·
Registered
Joined
·
2,812 Posts
Doesn't sound like has anything to do with the X-Pipe, but more to do with the air/fuel mixture. Whatever is causing the tuner not to work is probably the culprit.
 

·
Registered
Joined
·
1,381 Posts
k now shouyld my car idle alil more rough with the o/r x pipe then it did withg my o/r h pipe and y does smoke come out of my exhaust it never did it before i switched my o/r h pipe to the o/r x
smoke out of your tail pipes is normal unless the xpipe was used.. its just burning the coating off.. as far as the idle not being right im not sure
 
1 - 8 of 8 Posts
Top