Modded Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
ok somebody tell me what exactly is going on with my clutch. or whatever it may be!??. im pretty mechanically inclined. but im not an expert. i have a 91 5.0 5spd with a few engine modifications and multiple body modifications. but thats besides the point.. Ill give you a scenario, say im driving. cruising in 3rd or something. and i hit the gas. itll rev up but not catch right away. it will still be accelerating just not how it was. this just happened two days ago it started. but if i drive normally i have no problem really. so my guess is my clutch is just starting on its way out?. or what? help!?
 

·
Registered
Joined
·
11,200 Posts
Try ajusting your clutch cable
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
the quadrant?. , i dont think i have the firewall adjuster.. i wasnt sure if that mattered for what its doing. cause going through the gears is not a problem at all. no grinding. dont have to push it to the floor or anything. so i wasnt positive.
 

·
Registered
Joined
·
11,200 Posts
If its an after market cable there should be two nuts under the cover where the cable goes into the tranny( tighten the cable with the two nuts). If its stock then i think you need to pull up on the clutch pedal, you should hear a clicking noise
 

·
Registered
Joined
·
61 Posts
Not to hijack But I feel no need for a new thread.

simply put, transmission shifts like butter at times then at other times I feel like I need to "hadouken" it to get it into gear. check shifter cable? i am leaning to the throw out bearing. but hey, I have no idea what i am talking about.
 
1 - 5 of 5 Posts
Top