Modded Mustang Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
I've been having idle issues for a while now. I replaced my IAC and it has improved a little. But if I leave the IAC plugged in the rpms will hang for awhile and then drop down. And when I go to shift instead of the rpms dropping they will rise. But if its unplugged the rpms will drop like their supposed to. At lights tho, the idle will wonder all over the place and in the morning it will idle really low. Any ideas on what to try next? I heard i could possibly clean my MAF. How do i do this?

Thanks
 

·
Registered
Joined
·
2,950 Posts
that sounds like a vacuum leak to me
 

·
Registered
Joined
·
74 Posts
Discussion Starter #3
I've already checked for vacuum leaks. I'm leaning towards it being the MAF. I might try cleaning it. Are there any directions for cleaning it? with pictures and stuff?
 

·
Registered
Joined
·
74 Posts
Discussion Starter #5
I don't know what a TPS is sorry... If you could please explain?
 

·
Registered
Joined
·
437 Posts
TPS stands for throttle position sensor.
 

·
Registered
Joined
·
157 Posts
It's a throttle position sensor and it's usually found right around, probably on your throttle body, thats if you have one. I forget exactly how it works but I beleive it has something to do with the position of the butterfly. It's usually a very little peice with a plug and held on by 2 bolts, smaller then your IAC. It's a common thing to fail on a car like my focus, usually every 12k.

Thats also another thing to check, make sure the butterfly is'nt being held slightly open by something like build up. Thats not a bad thing to take off and spray down with some carb cleaner, it could be hanging up somewhere.
 
1 - 7 of 7 Posts
Top