Modded Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,002 Posts
Discussion Starter #1
hey i got a problem. my car is idleing weird, it drops to 500 and doesnt stall out..it seems like the throttle is sticking cause during some shifts the rpms jump. also at red lights the car used to idle at about 1200 rpms but had to sit there for a second before it went down to 1200 but not long..somtimes is dles fine..and i can be cruising down the road and push the clutch in cause im coming to a turn and the rpms just drop right away to 1000..any suggestions?
 

·
Resident Headbanger
Joined
·
2,419 Posts
Sounds like your idle air control motor may be sticking. Remove it from the throttle body and clean it thoroughly. If that doesn't help you may need to get a new replacement.
 

·
Registered
Joined
·
386 Posts
Yes the TPS and IAC are on the throttle body. I would suggest just changing it. If your car has alot of miles on it cleaning it won't do much good.
 

·
Registered
Joined
·
1,002 Posts
Discussion Starter #5
o my bad i see that u said it in the last message but what is it exactly..
 

·
Registered
Joined
·
1,002 Posts
Discussion Starter #6
well i cleaned out the throttle body and intake it was pretty bad and i tried driving it and it wont drive..it jerks pretty hard when i try to accelerate..i should just buy new TPS and IAC?
 

·
Resident Headbanger
Joined
·
2,419 Posts
If they're still the original ones that your Stang had from the factory, the answer is yes for both.
 

·
Registered
Joined
·
1,002 Posts
Discussion Starter #8
yea i changed the IAC and the TPS wasnt in stock..i put that on and cleaned everything out and it stayed at 3000 so next is the TPS..
 

·
Resident Headbanger
Joined
·
2,419 Posts
Wait a minute. You're saying that your idle is now stuck at 3000rpm? If that's the case, you have a vacuum leak so you might wanna check that out before you spend money on a new TPS. Did you remember to put back the rubber hose that goes from the valve cover breather to the airpipe?
 

·
Registered
Joined
·
1,002 Posts
Discussion Starter #11
lol yea i did that i noticed it right after i did it..i dont kno why i typed that in there..up in the clouds a bit after working on my car all day...i tried driving it and it kept jerkin like crazy..it reved up to 3000 rpms and cam down some then some more to 1600and i would hit the gas and it would move around and do mostly the same stuff
 

·
Registered
Joined
·
1,112 Posts
i would check all your vacuum hoses anyways... along with your TPS. Also, when you put the TPS and the IAC back on, make sure you put them in EXACTLY the same position they came off in... i.e. facing the same direction and everything, because that will affect everything!
 

·
Registered
Joined
·
1,002 Posts
Discussion Starter #13
the tps and iac only go on one way..the only thing i think about on the IAC is the gasket..im pretty sure i put it back the way it came off.some of the vacuum hoses dont have and zip ties or metal clamps..like the one from the intake to the fuel regulator
 

·
Registered
Joined
·
1,002 Posts
Discussion Starter #14
the tps and iac only go on one way..the only thing i think about is the IAC gasket..im pretty sure i put it back the way it came off.some of the vacuum hoses dont have and zip ties or metal clamps..like the one from the intake to the fuel regulator[/]IAC GASKET*
 
1 - 14 of 14 Posts
Top