Modded Mustang Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
had a poor idle, put new 02s in cuz mine were bad cleared it up but still is loading up bad and sounds like the egr valve is bad cuz the valve not opening up its bucking on throttle and wot and not when deceleration and smells like carbon building up any ideas is it the egr most likely ? or maybe iac? not exactly sure just wanted some ideas thanks
 

·
Banned
Joined
·
3,385 Posts
egr is only functioning when in cruise condition.. you can simply unplug the wiring harness from the egr if you want it disabled. If you have a cracked or uncapped vacuum line to it that's a different story because then you'll have a vacuum leak.

Does the car have stock injectors and maf?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #4 ·
i thought the egr like recycled gas in to the intake ? because it smells like its not because it cant open up because its getting loaded up so much
 

·
Banned
Joined
·
3,385 Posts
i thought the egr like recycled gas in to the intake ? because it smells like its not because it cant open up because its getting loaded up so much

no egr is basically for smog and has slight effect on mpg. I'll post a link explaining what it does exactly and why but the short short version is it recycles spent gases back into the intake track with the clean air to reduction the amount of smog out put.

EGR Systems - how it works

And in our cars it's only active during cruising so at idle or wot it's not active and wouldn't cause problem. Only time I could see if causing a problem would be if it was stuck open which would result in a vacuum leak but your check engine light would be on with an error code stored and you'd have shitty idle.

Have you looked for error codes yet? is your check engine light on or does it come on at all during this?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #6 ·
okay, so its prob a vacuum leak would the leak cause the bucking that im getting ? cuz thats when im gettin it when im cruising really, havent looked for codes and yeah it comes on and off during it, my idle is **** right now its like 500 and on a cold start it wont keep i have to rev it for a little while
 
1 - 8 of 8 Posts
Top