Modded Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all.

Ao i have a 14 gt. It has a cj intake with a dual 65mm tb and a jlt cai and e85 injectors. I just bought the car and i knew it had this issue but since ill be going back to stock for a turbo next year its not a huge problem but here it goes...so when i turn on the car the rpms go up to 1750 then after about 10 secs th2y settle bqck down at 1k....now if i push the gas peddle slightly and let it go the rpms drop to 500 or sub and sometimes it will turn off...this happens with the ac on....now i turn off the ac and the rpms still drop but to 750 never lower...when im just dri ing it when im stopping at red light or to do turns in the neighborhood it will sometimes gurn off ...again only with ac on...with ac off rpms drop but it hasnt turned off on me yet...qny ideas?? Also i can see my battery voltage dip from 14.2 to 13.5 when i turn ac on but after a se ond or 2 it picks back up..ive been working with palm beach dyno on getting the tunes modified...but im trying to rule out alternator or something else i may be missing..i have cleaned the tb already. Also installed 2 new breathers...everything seems to be nicly sealed up so i dont suspect a vaccum leak.
 

·
Registered
Joined
·
4,501 Posts
When my alternator died in my 02 gt it would flatout die with the ac turned on so its possible yours is weak but I doubr it. Have you had it load tested? How old is the battery?
 

·
Registered
Joined
·
4,501 Posts
Gotcha. Yea Im thinking it could be as easy as one of those things or its tune related.
 
1 - 4 of 4 Posts
Top