Modded Mustang Forums banner

1 - 20 of 53 Posts

·
Registered
Joined
·
1,762 Posts
Discussion Starter #1
I bought my kit from rpmoutlet for a good deal (i think it was) and well put it all on and all that good stuff but the new pulley tensioner was too far forward causing the belt to grind itself into oblivion from contact with the metal. It was a simple fix i just had to buy some 5/16th or something washers and put 3 on each of the three bolts that connect smaller plate to the bigger plate. But now im getting a "cylinder head over temp" check engine light. Im gona find out tomorrow if it just needs more coolant, i hope. but its an over all very complete kit with least amount of fabrication.
 

·
Registered
Joined
·
965 Posts
cylinder head over temp is a very not good thing.. hope you figure out the cause. alldata only shows something to do with the coolant system being potentially bad or your CHT sensor which seems unlikely that it would just happen to go bad right after the s/c install
 

·
Registered
Joined
·
1,762 Posts
Discussion Starter #4
well thanks to pep boys i had to put half a bottle of anti freeze in it. i dont know how i drove 1900 miles and its just now over heating
 

·
Registered
Joined
·
1,762 Posts
Discussion Starter #11 (Edited)

i could probably push about 310 now that im in georgia which has 93 octane instead of ****ing 91 in az. but traction is a giant problem at the moment.
 

·
Registered
Joined
·
1,522 Posts
build one my friend
 
1 - 20 of 53 Posts
Top