Modded Mustang Forums banner

1 - 5 of 5 Posts

·
DEC '12 ROTM CO-Winner
Joined
·
5,081 Posts
Discussion Starter #1
Drove the car around a bit today and took it out to take a couple pictures. Well made a stop and got back in and all was normal. When I got home and parked it I turned the key off and the car kept running. Key was completely out and it continued like nothing happened. Regular idle and everything. I opened the hood and just pulled the distributor plug to turn the car off. Tried starting it again and turned it off and the same thing happened.

What could cause this? My best guess was either the solenoid sticking or and ignition wire having problems. Any help is appreciated :yes
 

·
Registered
Joined
·
1,351 Posts
Take a multimeter or a test light and see if the ignition is getting power when the key is out. Since this just started (barring any recent wiring changes you haven't mentioned) the most likely scenario is that the key contact on the back of the switch is no longer turning with the key cylinder. A new switch is not expensive and pretty easy to change out.
 

·
DEC '12 ROTM CO-Winner
Joined
·
5,081 Posts
Discussion Starter #5
Take a multimeter or a test light and see if the ignition is getting power when the key is out. Since this just started (barring any recent wiring changes you haven't mentioned) the most likely scenario is that the key contact on the back of the switch is no longer turning with the key cylinder. A new switch is not expensive and pretty easy to change out.
Thanks man, I've got work soon so i'll have to take a stab at this tomorrow morning. I went out a couple minutes ago to disconnect the battery and I started it up first and it shut off fine that time. It isn't consistent with this apparently :dunno
 
1 - 5 of 5 Posts
Top