Modded Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
Quick question, bought my car used done some mods, some already done to it. I belive these are stock but I want to make sure. If you can tell by the picture please let me know. I know my CAI is MAC, or atleast the filter is, if its not id love to know what it is :D.

The bar code I found on the back of the plenum, not sure if it will help, just surpised it was back there, got to love cameras.

Thanks

Tony
 

·
Registered
Joined
·
468 Posts
looks all stock and the CAI does look like a Mac....CLEAN UR ENGINE BAY!!!
 

·
Administrator
Joined
·
76,434 Posts
Stock
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #4 · (Edited)
Ya sir! Main reason engine bay is nasty is a pesky coolant leak I have had. And just now I believe I finally found it. After weeks of searching near the radiator and all connecting hoses, I start the car up again, all warmed up, rev it a few times from the throttle body looking for green stuff!

I see it come out the bottom, I get down start taking pics and looking around, its dripping down the outside of the tranny! No where near where I thought it be.

So I start looking at the back of the engine bay, low and behold I see some coolant collecting on top of my engine! I see a bunch of tubes, few go to the throttle body/plenum. One goes down into the engine. This one has a clip holding it on and there’s tons of corrosion on it. But nothing coming out. So I rev a few more, watch for leaks, nothing really coming out.

So! being the stellar mechanic I am, I figure I would put a little stress on it like if I was revving to 6k flying down the road. I grab the tube and give a couple shakes and walah! There goes the coolant, all under pressure shooting out by the tube! I run into the car, shut it off, come back and wait. I take a look at the tube, still connected, though its really wet with steam all around it.

So now I wait for it to cool, will disconnect that tube and push it all the way down and reconnect the clip, run down to autozone, buy a new clip put it on there. And refill yet again my coolant. Hope this is it, I so love my car, hope this is really it :p

And here is the picture, makes me want to say DUH! looking at it, but I really didnt think there was a coolant tube back there, just though all that mess was when my first radaitor blew up, prob from a coolant leak :p

Now to find that engine bay cleaning post.
 

·
Registered
Joined
·
468 Posts
haha i love those "stellar mechanic" moments....good luck
 

·
Registered
Joined
·
927 Posts
have a full pic ?
 
1 - 6 of 6 Posts
Top