Modded Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,178 Posts
Discussion Starter #1
I have a 95 mustang GT with a 5 speed and when sometimes during acceleration, it jerks like fuel is cutting out. So my first thought was, its an older car maybe the fuel filter. I think all around it probably needs a tune up, but i wanted to see what you guys thought.

I know this isnt really tech, but im also having trouble with the Mach 460 System in the GT.
I installed a kenwood head unit. It had an old KW HU in there, so i didnt have to rewire a harness but i did wire in 2 12 kicker comps that work fine. Also i wired up 2 KW door speakers, and they did not work. What do i need to do for these door speakers to work? All i did was removed the stock speaker, cut and strip the speaker wires and solder them to the new speaker wires. I want to use the stock amps in the car for the door speakers. I read somewhere i might need to bypass the Mach 460 harness but im not sure how to do it.

Any help would be great! Thanks guys
__________________
 

·
Registered
Joined
·
7 Posts
If it jerks, like a surge in power, then it is your spark plugs. For that year, for that model, i would go ahead and replace all the plugs and wires, use OEM parts.
 

·
Registered
Joined
·
99 Posts
I have a 01 and it does the same thing. I replaced the spark plugs and it seems to still do it slightly. I need to replace the fuel filter and see what happens. and, as far as the speakers, mine didn't work either. you are going to have to run wires straight from the head unit to the speakers. thats the easiest way to do it
 
  • Like
Reactions: 2000stallion

·
Registered
Joined
·
2,178 Posts
Discussion Starter #6
I see..my head unit only has one set of a/v ports on the back. Can i get a splitter and can i wire them to the stock amps?
 
1 - 6 of 6 Posts
Top