Modded Mustang Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter #1
just wondering if anybody has a problem with their kb. i installed my kb but could not get it running right so i sent it to a pro shop, after data logging on a dyno we found 290 hp - 6lbs boost and only 8 deg total timing. wtf! after another dyno data log and a quick parking lot warm up the f'n kb froze up solid. wondering if anybody has had a somewhat similar problem? or is it just me that can't win with their car. btw this is my second motor with a total 5,000 mi on the clock. (piston failure)
 

·
Registered
Joined
·
2,791 Posts
Something is really wrong there with the tune. I saw 21 degrees of timing 9 psi. and 470 rwhp.

What did KB say about the blower?
 

·
Registered
Joined
·
174 Posts
Discussion Starter #3
kb said to send it back to them and they'll check it out and rebuilt it if necessary. as for the tune who the hell knows. i wish somebody knew a little more about that steeda adaptive tune contraption, i would consider getting that if its any good.
 

·
Registered
Joined
·
2,791 Posts
not worth it. By a Big Stuff 3 and call it a day. If it locked up I would hope they would rebuild it. I have an what were the air temps when datalogging. That blower was probably hot as hell and that is why there wasn't any timing. Also was it intercooled?
 

·
May 08 ROTM
Joined
·
7,192 Posts
A dumb question, but I always go back to the basics and never assume anything - Did you remember to fill it with oil prior to use?

KB's are as straight forward as they come, some of the install was obviously an after thought, but overall the system is tried and true.. Hopefully everything works out for you in the end.
 

·
Registered
Joined
·
817 Posts
I was about to ask him the same question concerning oil.I have the same kit non intercooled and i'm making about 370 rwh about 368 torque so something thing is wrong.
 

·
Registered
Joined
·
174 Posts
Discussion Starter #7
its not a stupid question but yeah i filled the oil to the proper level, so i know that wasn't the problem, and yes it is a intercooled 9psi unit. i'm hoping that the blower was really tight thats why it made no power and subsequently had little timing. btw what is the big stuff 3 i've never heard of it?
 

·
Premium Member
Joined
·
159 Posts
As far as tuning goes, the factory PCM can be tuned to work on 600-1000RWHP cars, theres not a reason to switch.

The steeda tune would not work in this case due to the particular combination of kenne bell spec parts on the car. This does not mean the steeda tune is bad, things are just configured a little differently and from what I can tell from their literature the steeda tune is one size fits all.

It's hard to say whats going on with your current KB tune without seeing a bunch of data.
 

·
Registered
Joined
·
174 Posts
Discussion Starter #9
i finally found out why my blower seized up the other day, a big ol chunk of aluminum in the rotors. now i need / hope kenne bell will cover the damage, as for the lack of power i hope that the chunk was the problem. maybe the piece of alumn was causing a rattle thus making the knock sensors retard the timing.
 

·
The Despised Vert
Joined
·
3,557 Posts
Where did this chunk come from.... this is not normal or good
 

·
Registered
Joined
·
817 Posts
DudE I would send that thing back and get a replacement.You better check the manifold and intercooler just in case some of that metal made it in.
 

·
Registered
Joined
·
37 Posts
Yeah definitely check the motor, you might should even pull the heads, you dont want ANY of that aluminum flying around in there. That really sucks. It sounds like the screws may have been touching causing excess drag and heat, which would likely shatter a screw and cause the PCM to pull timing. Maybe KB just aligned the screws wrong when building the damn thing. In any case that has to be the saddest story ever. I know you went from being the happiest person alive to the most pissed off in history in no time.
 

·
Registered
Joined
·
174 Posts
Discussion Starter #15
when i pulled off the blower i found a large chunk of alumn, i also checked the intercooler and saw a few flakes of alumn on top of it, luckily large pieces on metal can't go through the intercooler. i'm gong to pull the manifold off to replace the knock sensors and to vacuum out the intake and cylinders. heres the kicker to this whole story, right after installing the blower, without driving it mind you, the motor broke a piston and i had to replace the motor. so basically for the last 8 weeks i haven't been able to drive my new kb blown mustang. btw the orig motor has only 5k on it.
 
1 - 15 of 15 Posts
Top