Modded Mustang Forums banner
1 - 20 of 25 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
first let me explain my story as quickly as i can. i have an '07 v6. i wanted long tube. i researched a little and then bought the MAC ceramic coated long tubes. good choice right? or so i thought. i got them in and couldn't get them to line up. they told me to send them in so i did. they made ME pay for shipping. i wait for 2 weeks and call to get an update and they tell me theyre JUST NOW getting around to looking at them. i tell them they need to now, he calls me back 15 minutes later only to tell me there wasn't a problem. it took them 10 buisness days to do a 15 minute test? they sent them back and said there was nothing wrong with them. :rolleyes: alright, i get them back today and i was installing them. turns out the base of the port (look at the pictures below) interferes with the bolt that holds my coil pack in place. :mad: when i push it up against the bolt on the coil pack (it's on the port closest to the firewall) the front most port is a full inch off. has anyone else done long tubes at all? it looks like it just needs to be grinded. at this point i think i'm going to demand my money back from MAC and spend the extra 250 on the kooks long tubes. has anyone else had a problem like this? or has anyone even done long tubes on a v6 for that matter?
 

·
Registered
Joined
·
13,629 Posts
Where's the picture? And if the picture shows that it is off, send it to MAC and see what they say.
 

·
Registered
Joined
·
177 Posts
I had to talk to my MACs with a hammer to get them to fit properly:mad:
They seem to have issues sometimes.
 

·
Registered
Joined
·
978 Posts
a hammer!! WTF.........thats some serious "love" right there!! :D
 

·
booooost'd
Joined
·
7,545 Posts
I didn't install mine, so I don't know about the fitment too much, but the guy who installed mine said one of the tubes didn't line up right. He bolted up the tube and the bent the messed up one into place. He said I wasn't out much though.
 

·
Registered
Joined
·
2,134 Posts
My MACs fit like a glove. Everything lined up, tubes cleared everything perfectly. But everyone who has replied here has a V8, so that means nothing to the OP.

If the ports are off that much, take a picture for Mac. Are you sure you don't have the wrong part, like maybe a header for a 3.8 Mustang?
 

·
Premium Member
Joined
·
22,435 Posts
My MACs fit like a glove. Everything lined up, tubes cleared everything perfectly. But everyone who has replied here has a V8, so that means nothing to the OP.

If the ports are off that much, take a picture for Mac. Are you sure you don't have the wrong part, like maybe a header for a 3.8 Mustang?
Agreed!
 

·
Registered
Joined
·
177 Posts
Some people have had great fitting Mac products.
I unfortunately am not one of these people:rolleyes:
And to be fair I got them on ebay.Not from a reputable dealer.
 

·
Registered
Joined
·
2,134 Posts
I think that half of the problems people have with them are probable installer error. Unless there is a drastic variance in quality control, because like I said, mine fit perfect.
 

·
Registered
Joined
·
2,043 Posts
Hey nasty, please lose that avatar.
 

·
Registered
Joined
·
13,629 Posts

·
Registered
Joined
·
1,515 Posts
I agree!
 

·
May 08 ROTM
Joined
·
7,192 Posts
I saw QC issues early from mac in the V8 s197 versions. Since mid 08 they seem pretty good. Maybe this set was from their early runs. I experienced fitment issues that required "love" to make them work.

Take those pics and send them to whomever you purchased and MAC themselves.
 

·
Registered
Joined
·
2,043 Posts
Thanks Nasty, that was nasty. I even left my wife alone after that ****.
 
1 - 20 of 25 Posts
Top