Modded Mustang Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
hey guys new to this site.just picked up a 96 cobra about a month ago with 18000 org miles.today the sound system started poping and makin funny noise.no music was playing and i couldnt turn down the poping so i turned it off then back on and the same thing happened,then smoke started coming out from under the dash so i turned it off.the radio still has power but no music or poping now it wont do anything lol.almost sounded like the amps were doin something idk?any ideas wats going on?
 

·
Registered
Joined
·
105 Posts
Buy an aftermarket from crutchfield. It really brings the 460 to life. When you have it out, check all the wires, make sure yournot grounding out somewhere.
 

·
Rollin' 18/ pushin' 2
Joined
·
8,333 Posts
The stock head unit has no output. All the output comes from the amps, if your not hearing anything you would come out ahead by swapping to an aftermarket setup.
 

·
Registered
Joined
·
470 Posts
The stock head unit has no output. All the output comes from the amps, if your not hearing anything you would come out ahead by swapping to an aftermarket setup.
+1 get a nice deck that has mp3 + USB connections, i got one and love it since i can play my archos 500 GB internet tablet with music through the mp3 connection then charge my phone through the USB connection and have my radar detector/other goodies plugged into the 12v connection by the shifter. Get some subs and a 500+ watt amp too if your really into music like me.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #7
yeah i ordered a new deck and 4 6x8 jbl speakers.im just gonna gut the whole mach 460.wonder if i can use the same speaker wire that is already ran through the car?
 

·
Registered
Joined
·
470 Posts
did you get a deck with mp3 AND usb connections? you will end up really loving it if you did, specially if yours has 2 USB ports like mine and a mp3 connection its pure secks inside a car.
 
1 - 9 of 9 Posts
Top