Modded Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3,357 Posts
Discussion Starter #1
So as of late I have been getting a lot of fail to fires out of my maverick. I have cleaned an oiled everything over and over again, except for the trigger assembly. I have noticed that when the trigger is out if its cocked back and i pull the trigger, that most of the time the hammer doesnt go all the way forward to a fire position, it stops a notch ahead, and if i pull the trigger again it goes all the way forward.

I want to pull it apart and clean and oil the whole thing but nowhere have a found a break down on how to do so, and I know that I will certainly not do it right without some kind of guide. Does anyone know where I could go about finding one? or possibly where I could just go about getting a new assembly all together?

Or possibly anyone who has had a similar issue? Its driving me insane.
 

·
2012FFW TrueStreet Champ!
Joined
·
189 Posts
It sounds like its the trigger group to me. Also, have you checked to make sure the firing pin is moving correctly and not too stiff or hanging up? Those pin springs are very stiff sometimes! That could be an issue as well. If not, i'd send the trigger group back to Mossburg for repair or replacement!
 

·
Registered
Joined
·
3,357 Posts
Discussion Starter #3
I think I may have gotten it, I blasted the whole thing with cleaner a few days ago and put some oil on it, must have seeped in now, because just dry firing it I had no issues. I guess we will just see next time I go out.

Should it happen again, any idea how much mossberg would charge to disassemble clean and reassemble the whole trigger assembly?
 
1 - 4 of 4 Posts
Top