Modded Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 · (Edited)
So I have had this 99 mustang for a while and I decided to try and chase this sound in the exhaust at idle. I have true dual exhaust side pipes with rear 02 eliminators and no cats. At idle I can hear this puff happen every once in a while. I ended up lab scoping the secondary ignition bank 2 since I heard it less on this side. I noticed that ALL cylinders are misfiring. I pulled a plug, and I noticed they were burned pretty bad past 1.0 gap. I replaced all the spark plugs and gaped them to .50 and am still having the misfire on all cylinders. I swapped the coil pack with another mustang I have and it seems to have gotten worse, the spark seems very strong from the coil pack. I am not really good at reading the secondary wave forms, but I can definitely tell there is an issue with all cylinders. I ohmed out the coil pack, and it tested between .9-1.5 ohms at the connector. The waveform looks to me like it could be a fuel issue, I check fuel pressure and KOEO I have 25psi, and running I have 35psi. I have cleaned the MAF, and it did not seem dirty. I want some advice on what I should do now. Huge thanks for your time :)

Cylinder 3 misfire
https://gyazo.com/32bee7887e509216326d0414d40731be

Cylinder 3 throttle snap
https://gyazo.com/c4c0e9736844c69b4d4851f0f5662f9c

Cylinder 4 misfire
https://gyazo.com/b85a3352f277af5e4d1f3dde221cff70

Cylinder 4 throttle snap
https://gyazo.com/75427b3297fb67bbde24b834b6452a66

Cylinder 5
https://gyazo.com/c663f7b373199ff1acc97eaf5b5af0af

Cylinder 6
https://gyazo.com/a05953fe50e9fcbb69a34f8677071184
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #2 ·
I ended up smoking the intake manifold, and the intake manifold gasket is leaking along with the EGR gasket. Just ordered them and going to replace them when they arrive. Really weird waveforms though lol.
 

·
Registered
Joined
·
2 Posts
check your iac or whatever those little flaps are called that control idle. I have had a heck of a time with them on the 3.8L. When there not functioning right it will miss and idle rough. The clips breaks that hold the little arms in.
 
1 - 3 of 3 Posts
Top