Modded Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Ok I have a 2003 gt 5spd below 1700 in any gear the car will skip like its not getting fuel or spark but when u get above 17 it smooths out purrs like she should no rough idle either in neutral and no check engine light is on changed to motor raft plugs and the coil boots and it didn't help at all still the same.... Really need help with this my mods are as followed steeda underdrive pulley steeda intake and hi flow catted x all these mods were on car about three months or longer before this started so I don't think there causing it :icon_idea:
 

·
Registered
Joined
·
2,936 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #5
Changed plugs to bosh platinum 4s new coil boots and had the car checked and they couldn't find any codes at all wouldn't a bad coil through a code
 

·
Registered
Joined
·
2,936 Posts
The first thing I would do would be to throw away the silly 4 electrode plugs and install a set of Motorcraft or Champion single platinums--our cars fire all eight plugs with conventional polarity so double platinum plugs are not needed, and the combustion chamber was specifically designed for single electrode plugs.

Then test the COPs using an adjustable gap spark tester; any COP that can fire across a 1/2" air gap has nothing wrong with it.

If the problem persists check the compression and manifold vacuum. There are a number of things that can cause a stumble or misfire that will not trigger a DTC...
 

·
Registered
Joined
·
54 Posts
Discussion Starter #7
Thx the car is going back in the shop and the motor craft plugs are going back in having compression test done. As well as new vacuum lines found one today that had a small slit in it when we ran smoke through them under pressure
 

·
Registered
Joined
·
2,936 Posts
That's the problem with being dependent on someone else, they check all the easy stuff first, charge you money, and then (maybe) get down to the nitty-gritty...
 
1 - 8 of 8 Posts
Top