Modded Mustang Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
11,354 Posts
Discussion Starter · #1 ·
Ok well it is running just not well.
(mods in sig)

I have a guess of what it is but im not sure.

Ok so im in 1st and about to merge off a ramp onto a highway. (Lots of traffic).
I found my spot were I needed to merge and gave it a good id say 7/8 throttle... went up to like 4-5k and the front end droped down and it sounded like it was going to stall out.

Also when im on the highway or driving it sounds raspy. I feel like i have no power or like it wants to have power its just not.

Also when I pass on the highway and go half trottle to pass someone (half is all this car needs to fly by) the car surges. Not sure how i can explain it, but it surges power wise in mid range and it really bothers me.

I do have the stock fuel injectors on at the moment
What do you think it is.
 

·
Registered
Joined
·
212 Posts
do you have a check engine light on at all? I think i had a similar problem, i would check the spark plugs and see what they look like. My issue turned out to be my oxygen sensor just past my cats. But i ended up putting on new plugs,wires and coil packs along with the new sensor and the car stopped acting up. So IMO, im would say its an ignition problem...
 

·
Registered
Joined
·
1,935 Posts
+1 start with the east stuff i would give her a tune up.
 

·
Registered
Joined
·
11,354 Posts
Discussion Starter · #4 ·
No check engine lights yet. I called around and no one has any clues.

I really want to see if anyone else knows what it might be before i buy anything. As i am very very tight on money and only have 1 shot at it.
 

·
Doc
Joined
·
37,101 Posts
worth a shot, but go and give her a few good wide open throttle pulls.. then look under the car to see if one of your cats are red... You do not have enough info posted for us to really help you man.
 

·
Registered
Joined
·
11,354 Posts
Discussion Starter · #6 ·
What ever info you need let me know. I know its not a cat problem.

I think the car may be running lean but im not sure. The problem seems to be getting worse every day though so i dont think its that. I also have a feeling its the coil packs slowly going bad.

You can hear a slight pinging/ detonation wanting to start.

I cant take it to a ford dealer cause its going to cost me 100 bucks just to have them plug in a diagnostic and say well theres no codes... as i already checked.
 

·
mm's nitrous mod
Joined
·
12,988 Posts
sounding like fuel pump issue to me. only other things i can think of is tps, or timing (something like timingtrigger).
 

·
Registered
Joined
·
26 Posts
It has a 255lph Fuel pump, fuel pressure is fine.
This might sound stupid but did, you actually tape pressure gauge to the window then take it for a drive. Even if it is brand spanken new check it to make sure, I got burned a few times....LOL

Second, check tps, check both ohms and voltage.
 
1 - 11 of 11 Posts
Top