Modded Mustang Forums banner

Status
Not open for further replies.
1 - 20 of 82 Posts

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #1 ·
So my check engine light comes on and the car acts like a 4cyl. like when I gun it it want rev no higher then 3rpms and barly goes. so the check engine lights reads its a cam shaft sensor. so I changed it. still runs like a bitch...so I checked the wires, looks good! took that one back and bought a new sensor and re installed it. still runs like a bitch and the check engine light still reads its the cam shaft sensor. Im so mad right now..and so confussed.


what can it be?
 

·
Registered
Joined
·
7,994 Posts
Mine had that problem. Still does i think. I ran the tuner and it said that, i searched and it said alternator as well. Dont know if that could be the problem.\

And if you dont like mustangs buy a honda
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #4 ·
Mine had that problem. Still does i think. I ran the tuner and it said that, i searched and it said alternator as well. Dont know if that could be the problem.

And if you dont like mustangs buy a honda
Right now Id rather be driving a Kia, prob runs better. I mean this is my 3rd engine.


so you still have the problem? Mines so bad I cant even take off at red lights without looking like a 100 year old lady.
 

·
Registered
Joined
·
7,994 Posts
Well im on deployment, but when i put my car in storage i had the problem, but didnt have tiime to get it checked. It was like pushing down on the gas and it would barely go anywhere, no kick or acceleration or anything. It might need to be taken to a shop
 

·
Registered
Joined
·
1,864 Posts
Right now Id rather be driving a Kia, prob runs better. I mean this is my 3rd engine.


so you still have the problem? Mines so bad I cant even take off at red lights without looking like a 100 year old lady.
Your 3rd engine??? What are you doing to your poor car??
 

·
Registered
Joined
·
1,629 Posts
if its your cam sensor maybe the actual camshaft is messed up :dunno
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #9 ·
Well im on deployment, but when i put my car in storage i had the problem, but didnt have tiime to get it checked. It was like pushing down on the gas and it would barely go anywhere, no kick or acceleration or anything. It might need to be taken to a shop
So I checked the plugs and everthing looks good. I guess I'll have to take it back to ford. This blows!!! I hate that load of crap.
 

·
Noob Slayer
Joined
·
2,447 Posts

·
Registered
Joined
·
566 Posts
I'm not sure if you know this but theres this stuff called oil...and your motor tends to run better with some in it....just sayin. You must be doing something wrong because my 4.6 runs strong. I give it routine maintanence and never have any problems.
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #12 ·
I'm not sure if you know this but theres this stuff called oil...and your motor tends to run better with some in it....just sayin. You must be doing something wrong because my 4.6 runs strong. I give it routine maintanence and never have any problems.


Oil for the engine? Dude where do i go to buy something like that? Maybe have Ford order it for me?

Dude, I have the iol changed a month ago. I'll check it. Im sure its full though
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #13 ·
haha and i thought i was hard on my car. seriously though 3rd engine?
Yepp. The 98 blew up, so I bought a 04 engine from ford. with a 100k miles warentee. blew it up after about 4 months and just had them put a new 04 in there 3 months ago.
 

·
Registered
Joined
·
119 Posts
The problem is that either the engines they are putting in already have problems or they didn't put it in right or you are really tough on your vehicles.
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #15 ·
The engines are brand new,Ford is putting them in. Im not hard on my car either. I mean I thought a mustang could take a few hard take offs once in a while. My cousin has a 04 and he hits on that car so hard. never has a problem with it. I think ford needs to learn how to put a engine in right I guess. Fu.. my car
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #17 ·
whats that?
 

·
Registered
Joined
·
1,375 Posts
Discussion Starter · #20 ·
1 - 20 of 82 Posts
Status
Not open for further replies.
Top