Modded Mustang Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
86 Posts
Discussion Starter #1 (Edited)
I am installing my new JLT CAI in my 2010 right now (midnight MN time).

WHen I was uninstalling the factory stuff, I had to unplug a gizmo (PVC Valve?) on the left side of the intake very close to the throttle body. Its a short 18" cable that connects to the passenger side of the engine.

Anywho, the CAI kit came with a rubber hose extension. I am at the last stges of installing the CAI and I am not seeing how I hook the PVC plug into the new CAI. :sorry

I will try to attach a photo.

HELP!
 

·
Registered
Joined
·
69 Posts
I am installing my new JLT CAI in my 2010 right now (midnight MN time).

WHen I was uninstalling the factory stuff, I had to unplug a gizmo (PVC Valve?) on the left side of the intake very close to the throttle body. Its a short 18" cable that connects to the passenger side of the engine.

Anywho, the CAI kit came with a rubber hose extension. I am at the last stges of installing the CAI and I am not seeing how I hook the PVC plug into the new CAI. :sorry

I will try to attach a photo.

HELP!
The Hose just slips over the nipple without the orginal attachment mechanism of the stock unit.
 

·
Registered
Joined
·
86 Posts
Discussion Starter #3
I AM DUMB!

I had the tube in my hand, and the way I was holding it I didnt see the nipple. I undid the attachment at the engine like you said TStang, and I got her all hooked up.

Cant wait to test her this weekend.

And yes, I do have a custom Bama Tune on my SCT Tuner from AM.
 
1 - 3 of 3 Posts
Top