Modded Mustang Forums banner
1 - 8 of 8 Posts

· Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
This morning went to start the car, think I heard a pop from fuse box but not sure, after that no electricity. Car won't start, no backlights on dash, but the dome light was flashing. Didn't have time to check it out plus it was still dark out. Does this sound like a simple blown fuse or could it be something else?
 

· Registered
Joined
·
65 Posts
Discussion Starter · #3 ·
i forgot to mention that while the dome light was flashing there was a clicking noise coming from under the front left area of the dash. Maybe the fuse box? I don't know. The clicking sounded kinda like the turn signal, but different for sure.
 

· Registered
Joined
·
2,095 Posts
All I can tell you is it's probably one of the main fuses under the hood, one of the big ass ones running 40 or 50 amps. something like that.

You can either pull them one at a time and check them, or you can look in your ford manual and get the location of the starter and or ignition relay/ fuse and check to see if that one is out first to save time.

there are fuses under the hood, and then their are fuses under the drivers side dash too.

Your best bet is a major one under the hood though. Hope this helps.
 

· Registered
Joined
·
5,187 Posts
All I can tell you is it's probably one of the main fuses under the hood, one of the big ass ones running 40 or 50 amps. something like that.

You can either pull them one at a time and check them, or you can look in your ford manual and get the location of the starter and or ignition relay/ fuse and check to see if that one is out first to save time.

there are fuses under the hood, and then their are fuses under the drivers side dash too.

Your best bet is a major one under the hood though. Hope this helps.
+1
+ Reps for good info.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top