Modded Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
finally got my mustang up and running again. I had originally got it in June and had the engine replaced with another brand new 4.6L crate engine... after a long couple months and several misunderstandings later its up and running and out of her break-in period.

just did some simple mods so far. Lowering Springs, New shocks, New headlights, HID's, intake, off road x pipe, flowmasters 40's and just got a predator tuner in a couple days ago.

Seem off to a good start. took a quick pic of it before it started raining.

what do you guys think?

 

·
Registered
Joined
·
63 Posts
Discussion Starter #3
thanks! yes, I need more pics, weather has been pretty shitty here, so hoping for a dry day to shoot some photos.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #5
i bought it in June and had a very quiet ticking noise... didnt think anything of it, and kept driving it. Within a month, the ticking got ridiculously loud... It turns out it was a thrown bearing and the repairs and labor were pretty close to getting a whole new engine itself....

bad mistake on my part i guess... But now that she's up and running like a brand new car.
 

·
Registered
Joined
·
48 Posts
Good looking ride. I had to out a crate motor in my 2002 gt a while back (nitrous issue :)) it went pretty smooth and made it a no brained to put long tubes, k member etc. On at the same time.
 

·
Registered
Joined
·
63 Posts
Discussion Starter #9
Good looking ride. I had to out a crate motor in my 2002 gt a while back (nitrous issue :)) it went pretty smooth and made it a no brained to put long tubes, k member etc. On at the same time.
Yeah, I wish I would have done the same... but at the time I just wanted to get my car back and start driving again. lol. Going to eventually put in some longtubes, cams, etc once it starts getting dry. (Hopefully soon.)
 

·
Resident Diabetic...
Joined
·
1,827 Posts

·
Registered
Joined
·
296 Posts
why not get a 5.4 crate if you were going bran new?
 

·
Registered
Joined
·
4,547 Posts
What kind of break in did you do? Conventional oil for 3,000 miles. Change it after the first 50 miles. Cut the oil filter open and check it out. Then change it again at 1000 miles. then switch to syntehtic at 3,000 miles. Dont rag on the car at all for atleast 500 miles or so. Thats what i do but what did you do? Im curious to hear.
 
1 - 14 of 14 Posts
Top