Modded Mustang Forums banner

1 - 13 of 13 Posts

·
Administrator
Joined
·
76,434 Posts
Yeah that was at the MPH dyno day...

Fuel puddling at 4K for some reason...
 

·
MM's Mad Scientist
Joined
·
5,101 Posts
Looks like the infamous fuel puddle combined with too low an RPM. It happens to the best of us..........
 

·
MM's Mad Scientist
Joined
·
5,101 Posts
Yeah that was at the MPH dyno day...

Fuel puddling at 4K for some reason...

Well, scratch that RPM too low thing then. I sprayed mine at 3500 a few weeks ago and shelled out a PI intake. It blew the whole front runner out.
 

·
Administrator
Joined
·
76,434 Posts

·
Administrator
Joined
·
76,434 Posts

·
MM's Mad Scientist
Joined
·
5,101 Posts
3500 RPM?

I dont know whos tune the guy was running...
It just happens sometimes. Hell, I think what got mine is that I let my bottle pressure get over 1100PSI and it was tuned at 950PSI, but who knows. I am done with the wet shots on these small cube motors and long runner intakes.
 

·
N/A 4v Guru
Joined
·
3,484 Posts
What shot was he running? Bound to be more than 150
 

·
Administrator
Joined
·
76,434 Posts
It just happens sometimes. Hell, I think what got mine is that I let my bottle pressure get over 1100PSI and it was tuned at 950PSI, but who knows. I am done with the wet shots on these small cube motors and long runner intakes.
Yeah I know it just happens...

Its just crazy with the pictures...

I wonder what the final breakage was...
 

·
Administrator
Joined
·
76,434 Posts

·
N/A 4v Guru
Joined
·
3,484 Posts
Well at least I know the limit on my wet shot. Guess I will be sticking with the 100-130 shot.
 
1 - 13 of 13 Posts
Top