Modded Mustang Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,778 Posts
Discussion Starter #1
Drove up to subway..

Got in the car to leave, won't start. Jumped it off, got it going, and on the way home the charge meter barely moved - No charging.

Got home, cut it off, tried to crank it, dead.. spun once and clicked.

Put the battery from my drag car in, started right up.

Checked voltage at battery with volt meter - 16.5v!!!

My regulator is not working.. So the battery is good, either the alternator is done for, or my ignition switch is bad.

But heres the thing, always has been reliable until today. I plugged the maf connection tighter (not that i think that matters lol) and i pulled the power lock/window switch out and tried to fix them. Would any of that make the car act up?

One other thing I noticed was this. When im working on my cars, and usuing the key alot, to avoid the door ding, i pull the key half way out to make the chiming stop. Today I noticed that when I pull the key half way out, the chiming is still there.. sometimes I can pull the key all the way out and it still dings.

AND that the ignition switch leads back to the voltage regulator correct?

I'm thinking ignition switch because it tends to be a typical fox body problem around the same miles (114k)
 

·
Registered
Joined
·
142 Posts
When you pull the key out and it still dings can you turn it foward or backward with? also the dinging noise runs off parklights and headlights
 

·
Registered
Joined
·
142 Posts
Bad switch
 
1 - 5 of 5 Posts
Top