Modded Mustang Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have a 91 5.0 She was running great up until a few weeks ago. I noticed a loss in power, but didnt pay too much attention to it. It got gradually worse. Now I cant even get her down the street. When I push on the accelerator she tries to die, and I cant get her above 1500 rpms. Any ideas or suggestions? I took apart the entire intake and cleaned it.
 

·
Registered
Joined
·
7,599 Posts
Why did you take the intake manfifold off?

Regardess, scan for codes first. get a coppy wire and put it in the grey test port by the drivers side hood hinge and ground the other side and count how many time the check engine light flashed on the dash.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
I was advised by one of my friends that there can be lots of carbon build up in there. Since I live in arizona and havent cleaned it since before last summer I figured that it couldnt hurt with all of the dust out here. My check engine light isnt on, and has not been on since I first got the car. The guy I bought it from said it could be a fuel issue. I am going to rent a fuel pressure tester this week and check.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4 (Edited)
My check engine light is not on. I rented a fuel pressure tester. I had to turn it on (not start it) several times in order for it to build pressure. Once I started it it took a good minute for it to climb up to 45 psi. Could it be my fuel pump or pressure regulator?
 
1 - 4 of 4 Posts
Top