Modded Mustang Forums banner

1 - 20 of 41 Posts

·
Registered
Joined
·
307 Posts
Discussion Starter #1 (Edited)
i filled up to just over half a tank on wednesday night, ive driven about 40 miles and im at about 1/4 tank????? my milage seems to be getting worse each day. car is stock. this is under normal driving. no cel on. maintance done in the last week...

new air fliter
new plugs at .54
new fuel filter
checked psi in the tires
cleaned maf
cleaned iac
cleaned throttle body
full can on seafoam in the gas tank

my muffler is pretty rusted along the edges, could this be a problem? Too little back pressure? Could the o2 sensors be my problem, I bought the car at 48,000 last year and I doubt they have been replaced. Im at 56,xxx miles. I just dont want to spend $$$ on sensors and find out that it didnt solve my problem. any help guys, you rock. i have to figure this out, im too poor to be using this much gas.
 

·
Registered
Joined
·
1,868 Posts
i think o2 sensors usually throw a CEL :dunno
 

·
Registered
Joined
·
1,868 Posts
i filled up to just over half a tank on wednesday night, ive driven about 40 miles and im at about 1/4 tank????? my milage seems to be getting worse each day. car is stock. this is under normal driving. no cel on. maintance done in the last week...

new air fliter
new plugs at .54
new fuel filter
checked psi in the tires
cleaned maf
cleaned iac
cleaned throttle body
full can on seafoam in the gas tank

my muffler is pretty rusted along the edges, could this be a problem? Too little back pressure? Could the o2 sensors be my problem, I bought the car at 48,000 last year and I doubt they have been replaced. Im at 56,xxx miles. I just dont want to spend $$$ on sensors and find out that it didnt solve my problem. any help guys, you rock. i have to figure this out, im too poor to be using this much gas.
got a cel?
:p
 

·
Registered
Joined
·
307 Posts
Discussion Starter #5
yeah, no cel. this sucks muh ballz, i cud be drivin a 5.0 with better mpg right now
 

·
Doc
Joined
·
37,101 Posts
you might have a soft cel (shows no cel light)

plug in a tuner/auto zone special and see what comes up.

if nothing then your problem is mechanical
 

·
Registered
Joined
·
307 Posts
Discussion Starter #7
so i just go to autozone and ask them if they can find some codes?
 

·
Registered
Joined
·
1,868 Posts
guys and hmusn
:( :lol
 

·
Registered
Joined
·
1,868 Posts
:lol
 

·
Registered
Joined
·
307 Posts
Discussion Starter #15
im just really confused at why my car is running like normal but is getting such terrible mpg. does anything else at all come to mind?
 

·
Registered
Joined
·
1,868 Posts
keep the pedal off the metal?
 

·
Registered
Joined
·
1,868 Posts
maybe your odometer is messing up once or twice my trip will like reset somehow, usually like 20-30 miles after i fill up
so it looks like i have worse gas mileage. i watch it closely now a days
 

·
Registered
Joined
·
307 Posts
Discussion Starter #19
no pedal on the metal, and i know my odometer is pretty accurate
 
1 - 20 of 41 Posts
Top