Modded Mustang Forums banner

1 - 10 of 10 Posts

·
eeeee!
Joined
·
7,204 Posts
Discussion Starter #1
Yesterday was the first day I got to change the oil in my car. We put it up on the lift, and noticed there was A LOT of oil under the car.

You know where you screw the Oil Filter on? it goes onto a housing that bolts onto the block, its ALSO the water inlet for the engine, There is a gasket between the housing and the block , and on my car it was leaking, after we took it off, it was all squished down, I went to buy another one (Not knowing what this gasket was called) anyhow I got a new one and problem is all fixed now. but My question is, Is this a common problem? Ive never experienced this in anything before..
 

·
Registered
Joined
·
3,200 Posts
only thing ive ever heard of is the old gasket going bad on the oil filter and that leaking, but whatever at least you fixed it
 

·
Registered
Joined
·
3,200 Posts
no its def not the old gasket being on there, if you double gasket the oil will SHOOT out badly and you will loose all your oil in no time, thered be a trail following you where you go and youd have to put like 5 quarts of oil in your car in like 7 hours all the time you turn it on, double gasket is a very noticable thing
 

·
Registered
Joined
·
5,472 Posts
someone never scraped the old gasket off the block when the changed the oil last time is all.
The housing the oil filter screws to has a gasket between itself and the block. He is not meaning the oil filter gasket.
 

·
Registered
Joined
·
922 Posts
Ive never seen this to be a problem before.......
 

·
eeeee!
Joined
·
7,204 Posts
Discussion Starter #9
yeah it wasn't the Oil filter gasket, (I did that on my explorer once,, oops) this was behind the whole housing the oil filter screws onto. I wasnt sure if it was a common problem or if someone (before i owned my car) ****ed with it and didnt put it back on properly.
 

·
Registered
Joined
·
175 Posts
I belive I have the same problem. Everytime I change my oil or look under it my car. The entire area under the filter is moist. From the filter over the left control arm and the power steering pump, entire area is moist. Im going to be taking a real close look at all this on thursday since I dont have to work. But I thought it was coming from the filter block myself. Only thing is, I have changed my oil twice now, and it seems like there is no oil leak, my oil levels never go down over 3-4k miles. (I check weekly).

Other thing is I have a coolant leak which is my main subject on thursday to ID and fix, Im thinking that Im really seeing coolant sprayed over old oil and it just keeps it in a moist appearence. No idea, hoping I find some loose plug or something I can tighten up, because its a slow coolant leak, and I only see coolant on the ground after I go over a speed bump.
 
1 - 10 of 10 Posts
Top