Modded Mustang Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
i did a 2.3t motor swap into a 90 lx mustang and swapped a Stage 2 Racer Walsh cam into it before i ran it. i got it running but one of the cylinders are dead and its getting spark compression and gas and the timing is right but it just wont hit and i dont understand why not could it be the cam or what? its the 2nd cyl going from your right when your facing the spark plugs. i just dont understand could of be a intake value stuck half open??? its not the plugs or wires there brand new and the new spark plug i put on just keep getting filled full of gas and junk! so anybody know wtfs goin on?
 

·
Registered
Joined
·
54 Posts
Discussion Starter · #4 ·
cant be the fuel injectors there BRAND NEW out of the box cant be the plugs there brand new to and it fire fine cant be because of no compression it making better compression than some others the only thing i can think of is when i put this cam in a value is getting stuck midways
 

·
Registered
Joined
·
39 Posts
just do a leak down test. is easy, make sure that suspected cylinder has both valves close remove plug, go to auto parts store rent compression tester should have adabter and put some air in there,if you can hear air coming from throttle body, is intake valve, if you hear air coming from exhaust you know what valve is that or if you hear like the oil in oil pan bubbling those are rings. that gives an idea to track the problem. do you check the lift on the cam?
 
1 - 7 of 7 Posts
Top