Modded Mustang Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,789 Posts
Discussion Starter #1
first of all where is a good place to hide the 2 gauge wire I got? do i need a fuse? I have a holder with a 80 in it I can use? looking to see where i can run the wire Maybe the cowl panel? as my solenoids behind driver strut tower.
 

·
Registered
Joined
·
11,200 Posts
Yes, you need a fuse. My fuse holder that came with my wiring kit , fits perfect under the battery tray, on the frame rail. My fuse is a 200 amp but im sure youll be fine with a 150 amp fuse.

Ideally you want the fuse as close to the alternator as you can get it, but my wiring kit wasnt set up that way, it was set up to get the fuse close to the starter solenoid.

In a perfect world you should have two fuses. One on the battery cable just as the postive wire comes off the battery and another on the alternator as close to the alt as possible.

I hope this helps
 

·
Registered
Joined
·
1,789 Posts
Discussion Starter #3
Be nice under battery tray. But my battery isin back, and my aprons smoothed lol
 

·
Registered
Joined
·
7,599 Posts
Whats the fuse for? I did 1 wires on my old car and my dads and left the factory plugs un-done and everything worked perfect after haha. My car gone, but his is good.
 

·
Registered
Joined
·
11,200 Posts
The fuse is just for safty.... it will work if you dont have one.... but im sure you already knew that flattus, lol
 

·
Registered
Joined
·
1,789 Posts
Discussion Starter #6
Should charge really good with 2 ga copper cable lol

Sent from my SPH-D700 using AutoGuide.Com Free App
 
1 - 6 of 6 Posts
Top