Modded Mustang Forums banner
1 - 20 of 23 Posts

·
Registered
Joined
·
76 Posts
Discussion Starter · #1 ·
I finally got the nerve up to pull the valve covers and paint them. I went with body color (vapor silver) and I used Dupont Chroma Base coat/clear coat. They turned out better than expected and seem to be holding up fine with the engine heat. I will post pics when my wife returns with our cameras. To keep it tech. When I started the car it threw a tire pressure sensor code which I don't have. It cleared up within a minute or so and I did have the battery out. Anyone have this happen? Normal?
 

·
Registered
Joined
·
244 Posts
I thought 08's had a TPMS.
 

·
Registered
Joined
·
225 Posts
they do
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #7 ·
Don't I feel stupid. Sure enough I do have TPMS, just finished reading about it in the owners manual. Thanks for pointing this out.
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #14 ·
My wife will be back Saturday with the cameras so maybe Sunday I'll have pic's
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #18 ·
Pictures finally

I borrowed a camera. A little dark inside my garage, but you get the gist of how they look.



[/IMG]
 

·
Registered
Joined
·
76 Posts
Discussion Starter · #20 ·
I'm in the process of painting the inside of my wheels vapor silver. I think it will look much better than the dull gray the factory paints them with. I'll take pics before I post this time, assuming they turn out nice.
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top