Modded Mustang Forums banner

1 - 8 of 8 Posts

·
Hardcore Devotee
Joined
·
2,179 Posts
Discussion Starter #1
Hey guys,

I've tried googling this but I was wondering if anyone knows where I can find a part # for this metal line that's leaking on my 2000 GT? The leak seems to be getting worse and I want to get it taken care of but couldn't seem to find it.... I circled it in paint to give y'all and idea where I'm talking about.

Here are a few pics....

Here is where the leak actually is



As I traced it, looks like it heads up to this weird bracket thing? It was cold out and I'm getting over being sick so didn't wanna stay outside too long and I couldn't tell if the line is actually in multiple pieces or if its one solid piece?




From there it goes here from what I could tell....

 

·
Hardcore Devotee
Joined
·
2,179 Posts
Discussion Starter #3
Thanks man. I saw those before but wasn't sure if that was the line I needed. I'll give that a shot.
 

·
Registered
Joined
·
335 Posts
I had to make my own lines for a car I was rebuilding. No matter where I looked I couldn't find the pre-bent lines.
 

·
Super Moderator
Joined
·
13,581 Posts
take that line off the power steering pump and you will find a white Teflon washer on that line that has went bad its a easy fix and you can get the Teflon washer at any parts store.
 

·
6 Cylinduh, Really Bruh?
Joined
·
5,218 Posts
What pate said... typically the white Teflon o ring has gone bad.

When I redid my entire power steering system (hard lines and all) I bought all new high pressure lines (what you traced it to be from the hydroboost) off rock auto without an issue. Rock auto had everything I needed from the rack to the high pressure to the low pressure to the pump. If you need part numbers let me know but Rock auto is insanely easy to navigate. Just search for power steering high pressure lines.

If I were you I'd like at just replacing the Teflon o ring. I replaced the lines as a precaution. Over time the lines can rust from the inside out. Since I was replacing the rack and pump I figured why not do the high and low lines as well.

Good luck!

Sent from my SM-G920T1 using Tapatalk
 

·
Hardcore Devotee
Joined
·
2,179 Posts
Discussion Starter #8
Sorry guys, I have been super busy with work as I just started a new job and haven't had time to mess with it even. I am definitely going to try the washer thing first.

Looks like I may have a heater core going out now....My windshield fogs up as soon as I turn on the heat/defrost, i noticed some coolant missing, and I get a nasty nearly unbearable smell to go with it when the heat is turned on. Lucky me....
 
1 - 8 of 8 Posts
Top