Modded Mustang Forums banner

1 - 13 of 13 Posts

·
Banned
Joined
·
610 Posts
Discussion Starter #1
So I just picked my car back up after being in california for 6 months. My grandfather was supposed to take care of it for me but I guess he didn't really do that. I checked my air filter and noticed one side had some pink and green stains on it. Like some fluid had gotten in there. What could have caused this? I already replaced the filter so no worries about that.
 

·
Registered
Joined
·
461 Posts
is it a stock air filter?

How dark was the green?
Which side if you remember were the stains on?
 

·
Banned
Joined
·
610 Posts
Discussion Starter #4


This is the side with the stains. Dont know if it helps too much.
 

·
Banned
Joined
·
610 Posts
Discussion Starter #6
I was thinking antifreeze but i have no idea how any would have gotten in there.
 

·
a.k.a. Racecougar
Joined
·
4,775 Posts
Washer fluid, maybe? If you're really curious, try dripping various fluids on the filter and see what they look like once dried on there.
 

·
Registered
Joined
·
546 Posts
it almost looks like that colored foam stuff that car washes use.
 

·
Registered
Joined
·
461 Posts
The red looks like tranny fluid, which I have no idea how it got there since the transmission dipstick is on the complete other side of the engine bay.

The green looks like Coolant maybe he has a bad hose on the radiator and when it heats up it leaks and sprays like old faithful.

Are their stains on the underside of your hood? Is the coolant return hose in good shape, no cracks, no holes, good tight fit on the hose clamps? Check your transmission fluid level just to be safe.

Did you replace the filter?
Does the new filter have the same stains?
The only other option I can think of is there was some spray off the road when the car was being driven.
 

·
Registered
Joined
·
2,267 Posts
it almost looks like that colored foam stuff that car washes use.
i wouldnt rule this out, it makes sense if it was able to get into the wheel well. i always turn my car off on the auto washer because i fear my cai will suck the water and foam in:confused:
 

·
Banned
Joined
·
610 Posts
Discussion Starter #12
All my hoses are perfectly fine. Im thinking what wolfeman said could be it. The new filter I put in there doesn't have any stains on it. My grandpa had it and he might have taken it to an automatic car wash even though he knows I would never do that. All my fluid levels are fine so car wash stuff sounds the most plausible at this point. Thanks for all the help though guys.
 
1 - 13 of 13 Posts
Top