Modded Mustang Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
So I just assembled a 306 for an 86 GT. Right now these are the modifications:

AFR 185 non emmision heads, pn1388
FRPP e303 cam
FRPP hydraulic roller lifters
Trick flow push rods
Harland Sharp 1.6 Roller Rockers
Trick flow Track Heat upper and lower intake
BBK ceramic coated longtubes
BBK offroad X pipe

My problem is Im hearing a ton of valvetrain noise, Ive adjusted the valves to 1/4, 1/2, 3/4, and 1 turn of preload. measured for correct pushrod length, checked for rocker clearance under the valve covers. I contacted AFR and they said the FRPP lifters may not be handling the spring pressure of the 185's, which are 135 on the seat and 360 open. Everything I find says the FRPP lifters are fine for that pressure. What do you guys think? Im going to try and upload a video.

thanks in advance
 

·
Registered
Joined
·
4,875 Posts
^ what he said. Unless you got pistons cut for inline 2.02 heads, you're valves are most likely hitting the pistons. Check PTV before you do anything. Those spring pressures will work with those lifters. I ran more than that with them and didn't have a problem.
 

·
Registered
Joined
·
545 Posts
Im telling you man... that really sounds like piston to valve smack. Safest thing you can do is spend some time, and the money for another head gasket and pull the head. Im betting you will see something starting to wear or damage with that kinda noise.
 

·
Registered
Joined
·
616 Posts
Mechanically I'm not the brightest person by any means, but I can tell you I wouldn't let that engine turn over a single time more without pulling the heads.
 

·
Registered
Joined
·
4,875 Posts
Did you check PTV before you put it together? Just because they are notched doesn't mean it's enough. Always have to check.
 

·
Registered
Joined
·
23 Posts
i'm having a similar problem but another problem im having is i dont know how to start a thread or a post could you give me some advise
 

·
Registered
Joined
·
23 Posts
i tried everything i adjusted the first set of Pro Comp 7/16 stud roller rockers like 5 times from 1/4 turn all the way to 3/4 even while it was running, didnt sound as bad with the valve covers off. thinking maybee the tall valve covers are acting like a concert hall. then i went as far as buying a higher end set of rockers andstill have noise sounds like a sewing machine. but i do have a really fast closing cam i'm thinking theold stock lifters cant keep up i might go for a set of race rocker wth alot less travel and less squeeze.
 

·
Registered
Joined
·
2,466 Posts
On the main 5.0 page right above the threads and stickies their is a "new thread" button. Welcome to modded mustangs.
 

·
Mustang Fanatic
Joined
·
724 Posts
That sounds just like my valve train. I better check it out...
I thought I just needed new pushrods and lifters..
Tfs1 cam with gt40p heads usually don't have p to v issues do they?
 

·
Registered
Joined
·
23 Posts
no they dont i did wind up figuring out my problem it was the valve springs that Pro Comp installed on the heads i ordered from them they were 100 lbs more than it should have been. Changed the valve springs with the trick flow stage one springs and problem solved valve train is now quiet. Also i am running stock 1990 5.0 pistons with Pro Comp heads that are 175 intake runners with 202/160 intake exhaust and absolutely no clearance issues.
 
1 - 14 of 14 Posts
Top