Modded Mustang Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter · #1 ·
I have just recently bought a 98 gt with pi heads... i seem to be having trouble with coolant expelling from my reservoir cap... replaced thermostat, upper hose, the cap itself, did a coolant backflush... when driving it starts to overheat then spits coolant out and runs at the normal temp... what is the deal???
 

·
Registered
Joined
·
4,987 Posts
Are you sure the fans are coming on? me along with others i know have had similar issues with the fans not coming on and then overheating.

IF thats the case disconnect the battery and let it sit a sec then hook it back up to reset the ECU thats all we did when we had the issue and the fans then started to work like normal again.

Just to be sure you have a 16 PSI Cap Correct?
 

·
Registered
Joined
·
153 Posts
Discussion Starter · #3 ·
ya the cap is 16psi... the fan works it kicks on by itself and also runs when ac is on... i did a compression test and the cylinders are all around 125 psi... but i'm a rookie and did it cold forgot to warm it up... would that effect the test??
 

·
Registered
Joined
·
4,987 Posts
ya the cap is 16psi... the fan works it kicks on by itself and also runs when ac is on... i did a compression test and the cylinders are all around 125 psi... but i'm a rookie and did it cold forgot to warm it up... would that effect the test??
Yea, you should do it with the car warmed up like at a normal operation tempature and it will probably read higher when its warmed up because the pistons/rings etc are expanded/seated etc but if all of them are in the same range cold i wouldn't worry about it.

Also a Compression test is good to do, but your not looking in the right direction if its overheating in not going to have anything to do with compression... But atleast your making an effort to fix it;)

Even tho the T-Stat is new i would replace it with a better one. i personally purchase a no name T-Stat for my Daily mustang and a day or so after it ended up getting stuck closed and not working properly causing it to overheat etc and i ended up yanking it out on the side of the road and after work drove to the parts store and purchased a Stant T-Stat and have not had 1 issue out of the car in over a year now.
 

·
Registered
Joined
·
153 Posts
Discussion Starter · #5 ·
yes sir i bouoght a premium from napa 180 deg... now it really doesn't overheat it starts to get hot and drops to the R on normal... runs strong no! oil in my coolant or coolant in my oil.
i tremendously appreciate your input!
 

·
Registered
Joined
·
4,987 Posts
yes sir i bouoght a premium from napa 180 deg... now it really doesn't overheat it starts to get hot and drops to the R on normal... runs strong no! oil in my coolant or coolant in my oil.
i tremendously appreciate your input!
I ended up grabbing a 160 Stant and mine sits on the N lol.

No Problem just trying to help out a fellow Mustang owner;)
 
1 - 6 of 6 Posts
Top