Modded Mustang Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
730 Posts
Discussion Starter #1
last few weeks ibe been noticintg im loosing power.

went and got my engine light checked and no good news.

at first it was just an egr valve code P0402 (is there a way to get rid of the egr system all together or should i just fix it? )

now its two more, codes PO131 and P1171

can someone tell me what these codes are i know they have to do with O2 sensors and if so can i fix these with MIL eliminators, or do i need functioning O2 sensors to fix that?

ALSO i have a cracked manifold so im buying headers in like 3 weeks and i will be running a catless system... someone please explain to me how i can get my car back to good running order it feels like im dragging a coww.


[side note: i was waiting till i sobered up for this post and if it doesn't make sense i apologize lol]
 

·
I'm doing it wrong
Joined
·
5,495 Posts
Cracked manifold and bad O2's will do that to you man.

I would highly suggest at LEAST going and getting new O2's for the ones that are bad. You could possibly mess up your engine.

P0131...
What does that mean?

Essentially the same as P0136 and P0137, a P0131 code refers to the first oxygen sensor on Bank 1. P0131 means the O2 oxygen sensor's voltage remained low for longer than 2 minutes. This, is interpreted by the ECM as a low voltage condition and sets the MIL. Bank 1 Sensor 1 is located in front of the catalytic converter.

Symptoms

There may be no visible symptoms to the driver, other than the MIL (Check Engine / Service Engine Soon) illumination.

Causes

A code P0131 may mean that one or more of the following has happened:

Faulty o2 oxygen sensor
Short to voltage on O2 signal circuit
High resistance or open on O2 signal circuit
Possible Solutions

Replace faulty sensor
Repair short, open, or high resistance on o2 signal circuit
Are you sure the other code is P1171? If so then all I got was "Rotor sensor fault" I have NO idea what that is or what triggers it. I don't even know what that code is referring to. Re check that one if you can.
 

·
Registered
Joined
·
730 Posts
Discussion Starter #3
There may be no visible symptoms to the driver, other than the MIL (Check Engine / Service Engine Soon) illumination.
thats my favorite part lol... i can 100% tell its lost some signifigant power


yeah the p1171 is kinda fudged up it says its a general motors code?????????

heres what the paper says

Definition
heated oxygen sensor-bank 1 sensor 1
fuel system lean during acceleration

probable cause

1. failed (bank 1 sensor 1) sensor
2. fuel system lean - fuel filter blocked or fuel pump failure
3. poor electrical connection on sensor circuit


so i dont think its a bad fuel pump.... im imagining its just bad o2 sensors.... or the guy at autozone is a dumbass lol idk how a GM code is coming up

dam i would be soo mad at myself if all i had to do was replace the o2 sensors and my motor got effed up... butttt if im getting headers and will not be running cat's then what do i need the o2's for??? i mean this is maybe just me being ignorant lol
 

·
I'm doing it wrong
Joined
·
5,495 Posts
Which manifold is cracked? I am willing to bet its the one on the side that is making your O2's throw a code... And if that P1171 is a lean code of any sort it's probably because of the crack, it must be a pretty decent size crack right? It's probably letting some air in during acceleration that isn't being metered by the MAF causing your O2's to get a different reading than what the MAF is telling them should be getting into your engine. Your car feels like its bogging because too much air is in there (running lean).

Fix your manifold = problem solved.

Trust me, I have had every single exhaust related problem happen to me with my car. Manifolds breaking off from the flange, cats going bad, cracks in the manifold themselves. The crack itself actually made me run lean as well.
 

·
Registered
Joined
·
296 Posts
Good information.
Let us know when shes running correctly again. Yeah, the O2 sensors can fudge things up royally. I've been reading O2 sensor comments alot lately. Had to replace two of mine last week also.
 

·
Registered
Joined
·
158 Posts
I threw same code when my manifold was cracked. shop welded it up and code cleared itself in a week.
 

·
Absens haeres non erit
Joined
·
2,807 Posts
probable cause

1. failed (bank 1 sensor 1) sensor
2. fuel system lean - fuel filter blocked or fuel pump failure
Replace your first O2 sensor and your fuel filter. Then see how it feels.

You might as well do plugs while you are at it, and a seafoam treatment as well.

Also try some header repair putty. Most auto stores have it. It is a very temporary fix until you get the headers.

BTW The 2nd O2 sensor is redundant, all you need is a MIL eliminator for that one.
 

·
Registered
Joined
·
730 Posts
Discussion Starter #8 (Edited)
Replace your first O2 sensor and your fuel filter. Then see how it feels.

You might as well do plugs while you are at it, and a seafoam treatment as well.

Also try some header repair putty. Most auto stores have it. It is a very temporary fix until you get the headers.

BTW The 2nd O2 sensor is redundant, all you need is a MIL eliminator for that one.
thank you lol for answering that question :yes

so do i need an upstream or downstream sensor .... i found em for like 29 bucks on rockauto

also can someone tell me if pacesetter even makes headers for 99-00 6ers? all i can find is for 01-04 and mac for 99-00
 

·
Registered
Joined
·
461 Posts
you need O2 sensors, at least the up stream ones. They tell your engine if theres a good Fuel/Air ratio or if it needs to adjust it one way or another. The downstream O2 is kind of pointless. Get a Handheld tuner and disable the two down stream O2s.
 

·
Registered
Joined
·
730 Posts
Discussion Starter #12
ok so ive gathered that i need headers...(still want to confirm if the pacesetters will work)

and i need the upstream o2 sensors and i should be top notch SHOULD lol

then ill figure out the egr thing...
 

·
MOAR BOOST
Joined
·
9,163 Posts
You need a tune to delete EGR.

And as far as your car bogging, I just finally fixed my exhaust leak last night and it runs so much better. It ran like total balls when I had an exhaust leak, bogged down really bad. Although I still have a little bit of one, I think it might be my header : /
 

·
Registered
Joined
·
1,358 Posts
Sounds like it's just the cracked header causing all of your problems. Just go to a small shop and have it welded for like $20 and you should be good.

You might need to replace the upstream O2 sensor as well but I'm willing to bet it's functioning correctly and will work fine once your crack is fixed.
 
1 - 15 of 15 Posts
Top