Modded Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
just istalled a pro charger on my 08 gt/cs. I bought the P1SC complete kit including injectors,boost pump, diablo tune.
The car is haveing a hesitation in any gear at 2900 to 3000 RPMS no matter what, or how i drive. Wether accelaerating fast or slow.
I loaded the tune from diablo that came with the unit. The car has long tube headers, off road H, magnaflow exhaust. I know i need a dyno tune, and the appt is already set up. The question i have is....
Will the dyno fix this?
I was also told by pro charger to change the plugs and that could be the issue. They said to change to HT 0 (autolite). Is this true? Could this really really change the hesitation. Also said to try and re gap my current plugs to 32-35.
The car only has 18k miles and ran perfect before the pro charger.
Any insight would be greatly appreciated.
Anyone else have this issue with the procharger?
Thanks in advance.
 

·
Registered
Joined
·
600 Posts
1- colder range plugs
2- the tune doesn't include your headers, my guess a dyno tune will fix along with new plugs.
 

·
Registered
Joined
·
666 Posts
^^^ what he said. Those tunes they come with are scrappy IMO.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #4
thanks guys. Any reccomendations on plugs besides the autolites? Equivalent tempeture wise?
 

·
Registered
Joined
·
600 Posts
Everyone here recommends either those or Brisks. I plan on Brisk plugs when I change my stock ones out.
 

·
Registered
Joined
·
1 Posts
just istalled a pro charger on my 08 gt/cs. I bought the P1SC complete kit including injectors,boost pump, diablo tune.
The car is haveing a hesitation in any gear at 2900 to 3000 RPMS no matter what, or how i drive. Wether accelaerating fast or slow.
I loaded the tune from diablo that came with the unit. The car has long tube headers, off road H, magnaflow exhaust. I know i need a dyno tune, and the appt is already set up. The question i have is....
Will the dyno fix this?
I was also told by pro charger to change the plugs and that could be the issue. They said to change to HT 0 (autolite). Is this true? Could this really really change the hesitation. Also said to try and re gap my current plugs to 32-35.
The car only has 18k miles and ran perfect before the pro charger.
Any insight would be greatly appreciated.
Anyone else have this issue with the procharger?
Thanks in advance.
Colder plugs and a Dyno Tune... I have a 2004 GT Pro-Charged, went with big injectors, Cobra plugs changed fuel pump plus a few other things then off to the Dyno guy. Car runs like a champion the handheld tuner are useless when you step up to a super charger there good for bolt on stuff.
 

·
Registered
Joined
·
4 Posts
You changed injectors, did you change your maf or put a extender on?? Those canned tunes are crap. I wouldn't run a canned tune unless I was stock or had some sort of intake, exhaust ect. Def not with boost. Most run a NGK TR6 plug gapped at around .030-.032. I am running those plugs gapped at .030 and no spark blow out.

Also, Do you have a wideband?
The handheld is really only good for data logging, and of course needed for dyno tuning. Other than that mine is used for logging only.

Long story short, You need a dyno tune!!! I wouldn't drive it until that was done. I drove mine on and off the trailer that was it, I wasn't risking my new built motor. Get a wideband and take to tuner......
 
1 - 8 of 8 Posts
Top