Modded Mustang Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2005 Ford Mustang GT with a Pro Charger... with a Cervini's side exhaust, diablo chip. Car seems to want to shut off when stoped. but only after I installed the new exhaust. Anyone have this problem or any ideas?
 

·
Tini Tini Bo Bini
Joined
·
9,029 Posts
it wouldnt need a retune?
 

·
Tini Tini Bo Bini
Joined
·
9,029 Posts
does the side exhaust eliminate the mid pipe?
 

·
MM's resident Juice head
Joined
·
7,913 Posts
plug your tuner in and check for trouble codes...just because the light isint on doesint mean it isint throwing a code
 

·
All sissies going to Hell!
Joined
·
5,818 Posts
You may have changed also either the pressure or AFR. It might be super lean. I would go get it dyno tuned.

and I don't suppose you have a wide band?
 

·
Registered
Joined
·
3,680 Posts
the car NEEDS more timing advance in the lower rpms to help burn the increased intake flow.
 

·
May 08 ROTM
Joined
·
7,192 Posts
Running a procharger, same exhaust, no issues. I've been on the dyno 3 or 4 times since I installed the exhaust, but prior to those sessions the car ran fine.

Running headers / high flow cats on this car? If not your exhaust change would not fluctuate back pressure or A/F enough to cause stalling. The exhaust flows better, but it is not a free pass to the atmosphere. You still have mufflers, and if no headers, still have the cats and midpipe. Problem is lying elsewhere.

Check your maf sensor, be sure it's clean. Could be a coincidence that after the exhaust a routine maintenance item surfaced - especially with the blower on the car.
 
1 - 11 of 11 Posts
Top