Modded Mustang Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
666 Posts
Discussion Starter #1
So i got my car on the dyno last week and at 5000 rpm belt started slipping and it showed only 6 pounds all the way to 6000. I called procharger they are sending me a smaller belt and smaller pulley to reach 10 pounds. Thw numbers are pretty low its at 400 rwhp. Has anybody here had this problem
 

·
Registered
Joined
·
2,308 Posts
so, you dynoed at 400rwhp, but your sig says 482?


maybe a belt tension issue?
 

·
Registered
Joined
·
666 Posts
Discussion Starter #3
Yea thats y i got it dynoed again i thought the boost guage was reading wrong but i guess its right. When i got it dyno tuned it put down 482. my tuner said a new belt and pully should do it because i was pushing 8.5 pounds before
 

·
Registered
Joined
·
666 Posts
Discussion Starter #4
Its not the tensioner we have adjusted it many times and no go
 

·
The Mustang Shop
Joined
·
445 Posts
Its not the tensioner we have adjusted it many times and no go
Not trying to insult you. Are you sure you are adjusting it correctly? I have never heard of a 05+ that had belt slip issues. I make 23lbs of boost with my race tune and I have never had the belt slip.
 

·
Registered
Joined
·
666 Posts
Discussion Starter #6
Im not the one adjusting it its a procharger shop. And another guy around here had the same problem and he got a smaller belt installed and fixed the problem. Just wanted to see if anybody else has ever had this problem
 

·
Registered
Joined
·
548 Posts
Not trying to insult you. Are you sure you are adjusting it correctly? I have never heard of a 05+ that had belt slip issues. I make 23lbs of boost with my race tune and I have never had the belt slip.
^this, its a dedicated drive system so there should be no best slip at such low boost numbers
 

·
Registered
Joined
·
2,308 Posts
im at 10lbs with no slip with a vortec. if the tensioner isnt just right you have slippage. also, it could be the wrong tensioner for the belt being used and the pulley being used. the pulley and belt play a part in the tensioner.
i know you say this isnt the issue, but id relook into it
 
1 - 8 of 8 Posts
Top