Modded Mustang Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
I installed my ASP underdrive pulley this weekend, and ever since I did there are spots on and around my pulley where it looks like it's flinging oil around. I'm sure this isn't normal. What should I do?
 

·
Registered
Joined
·
55 Posts
the seals are leaking you need to have that fixed it will just keep leaking when your moving prob not while sitting in the driveway. i had the same problem
 

·
Registered
Joined
·
222 Posts
Discussion Starter #3
Is there a replacement seal I can buy or do I need to take it to a shop?
 

·
Registered
Joined
·
1,006 Posts
youre gonna need a press tool for the seal as well. but i would just have a shop do it unless you know how. you dont want to attempt it and damage the new seal and have it leak too
 

·
Registered
Joined
·
222 Posts
Discussion Starter #8
Well I think I got it on okay. Haven't had a chance to look down there to see if there's still a leak. I picked up a seal at the Ford dealer today. Now, I have another question. Ever since the first time I installed the pulley, I've heard what sounds like metal rattling whenever I'm accelerating and my RPM's get around 2250-2500. A buddy and I searched and searched, and the only thing we can come up with is maybe where the headers connect to the y-pipe because I installed my shorties a few days before, but nothing ever rattled until the pulley was installed. Any ideas?
 

·
Registered
Joined
·
1,006 Posts
Check all of the heat shields around your exhaust and see if the headers are touching them and causing them to rattle
 

·
Registered
Joined
·
55 Posts
yeah check near the panhard bar cause when i installed my exhaust i didnt align it right and it rattled a lot right on the bar.
 
1 - 10 of 10 Posts
Top