Modded Mustang Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
Ok. So i was at my uncles last night and some of today tinkering with the cobra. We have a major problem on our hands. My left side turbo is leaking and i don't know from where. All the tubing is fine. Do you think i need to rebuild it or is it somewhere else. It doesn't sound like its leaking from anywhere. The only reason i know its the left side is i have two boost gauges and the left one will drop out significantly but that s never happened before. Usually they spool up at the same time and are at the normal boost level give or take a few pounds. I'm worried. HELP ME

Twitch:(
 

·
N/A 4v Guru
Joined
·
3,484 Posts
Seperate blow off valves? One per side or just one. Check the impeller side, for cracks in the housing, downpipe flange leaks, etc. You can get exhaust leaks that will effect boost as well.
 

·
Premium Member
Joined
·
4,464 Posts
Make sure the waste gate signal line is not cracked or leaking. I would probably T off your vac boost signal with the same length tubing going to each waste gate. A smoke test would be a great idea when you have a complicate intake setup.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #7
alright thanks guys ill definately take a look at all those. I have two seperate BOV's. i didnt know my wastegate signal line could cause a boost problem
 

·
Premium Member
Joined
·
4,464 Posts
alright thanks guys ill definately take a look at all those. I have two seperate BOV's. i didnt know my wastegate signal line could cause a boost problem
The wastegate controls the boost. It slams shut to reroute the exhaust thru the turbine when you hit the gas, then opens back up a bit once you hit your preset boost level (this is so the boost does not keep going up higher).
 

·
Registered
Joined
·
54 Posts
Discussion Starter #9
The wastegate controls the boost. It slams shut to reroute the exhaust thru the turbine when you hit the gas, then opens back up a bit once you hit your preset boost level (this is so the boost does not keep going up higher).
i knew what it did i just didnt know it could cause that
 

·
Registered
Joined
·
2,238 Posts
Not trying to change the topic but... a Termi that runs 7.36 @ 196.4 mph...:pics:D
 

·
Registered
Joined
·
54 Posts
Discussion Starter #11
Not trying to change the topic but... a Termi that runs 7.36 @ 196.4 mph...:pics:D


Sorry this thing aint ready for pics but i will get them up as soon as i can. My uncle just punched it into the wall at the track before winter and we havent gotten it repainted yet. He sideswiped the wall...hes a dumbass
 

·
Registered
Joined
·
461 Posts
Im sorry but does anybody else feel that this is fishy, if you have a car that runs 7.3 at 196, you would not be asking this question on this forum. Anybody could tell you that in order to answer such a question you would have to be looking at the car, I just dont buy this. 7.3... thats major major mods and hella driving... are you sure this is your car?

p.s. Its probly the wastegate spring, or a there is a boost leak at a connection somewhere, I cant see your car so I cant tell you where to look, could even be an exhaust leak, there is just no way to tell on the internet...
 

·
Registered
Joined
·
54 Posts
Discussion Starter #13
this isnt fake. its taken us two hard years to biuld this car like this and both myself and my uncle(a certified master technician) are completely stumped. Its a very hard car to drive if ur not used to it. i almost crashed it pretty bad but i saved it.
 

·
N/A 4v Guru
Joined
·
3,484 Posts
I don't usualy call B.S. but you are gonna have to back up some of this. There are a couple things I know, and one of em is if you work on a car for 2 years, there are tons of pictures. 2. if your drive a car that runs 7's in the 1/4, there are pictures AND video. 3. your car has to weigh less quite a bit less than 3k lbs to get 7's with the horsepower you are claiming. You are gonna have to pony up some proof man or the B.S. flags are gonna fly.
 

·
Administrator
Joined
·
76,434 Posts
the last time i dynoed it i got 1384rwhp and about 1400ft lbs. i dont remember how much it wieghs but its tubbed
Did you ever find a way to lower your 1999 Pontiac Grand Am?
 

·
Premium Member
Joined
·
11,663 Posts
I found this thread interesting until I read the Webrides profile on the car and looked back through. Just under 8 seconds at close to 200 is real fast. Too fast for a car with a fiberglass body kit, 20 inch wheels, race interior and tubs and an air suspension? OK, maybe the last one, but I don't seem to remember seeing any 20" slicks. I could be wrong. But my BS flag is out!
 
1 - 19 of 19 Posts
Top