Modded Mustang Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
508 Posts
Discussion Starter · #1 ·
Wondering if you guys can figure this one out. So last week I had 3.73 gears, all new bearings and bushings, and new Moser axles installed with Royal Purple diff fluid. I picked the car up and when I took a turn I could hear the posi unit popping, sounded like something was binding?? Took it back to the shop and the guy said maybe it was the Royal Purple......I'm like WTF, lots of people use RP. So I changed the fluid Friday and I just put Valvoline back in with friction modifier.....and now the car is fine, no binding?? Doesn't make any sense.
 

·
Registered
Joined
·
470 Posts
Great... I got Royal Purple tranny fluid coming... I hope that crap aint as bad as their diff. fluid that you got.. So yeah what gives? RP is supposed to make things better not make em bind and snap crackle and pop! Maybe its just too new technology for our old 96's and our babys just need the good ol stuff? I'm not trying to steal your topic but does anyone else have good experiences with R.P tranny fluid and their differential fluid?
 

·
Registered
Joined
·
508 Posts
Discussion Starter · #3 ·
Ha...the only thing that I can think of, is RP already has friction modifier in it. So maybe it was to much with the RP and the posi additive he put in.
 

·
Registered
Joined
·
149 Posts
Wondering if you guys can figure this one out. So last week I had 3.73 gears, all new bearings and bushings, and new Moser axles installed with Royal Purple diff fluid. I picked the car up and when I took a turn I could hear the posi unit popping, sounded like something was binding?? Took it back to the shop and the guy said maybe it was the Royal Purple......I'm like WTF, lots of people use RP. So I changed the fluid Friday and I just put Valvoline back in with friction modifier.....and now the car is fine, no binding?? Doesn't make any sense.
I've read you still need to put the friction modifier in it even with the royal purple. I'm sure someone else will have more imput on it,
 

·
Registered
Joined
·
508 Posts
Discussion Starter · #5 ·
That's what i thought. I did add it with the Royal Purple.
 

·
Registered
Joined
·
678 Posts
I have run nothing but Royal Purple & a bottle of FoMoCo friction modifier in mine since I changed the gears in 2004 and have not had a single problem.
 

·
Registered
Joined
·
508 Posts
Discussion Starter · #8 ·
The Royal Purple was 75w and the Valvoline was 80w. That's the only thing that I could think of, that I shouldn't have added the friction modifier with the RP. The car is fine now with the Valvoline. No binding anymore.
 

·
Registered
Joined
·
105 Posts
I have a buddy that had a 240sx sr20 det motor in it. Pushing around 450hp to the wheels. The car ran great was a freakin beast. He put RP oil in at the next oil change, and within a week threw a rod. Thats the only experience ive been close to with RP.
 
1 - 9 of 9 Posts
Top