Modded Mustang Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
753 Posts
Discussion Starter · #1 · (Edited)
So my car has been having a problem in the lower rpm ranges with missing. It bucks and sputters when given just a little throttle right around 1500 rpms. Ive done some research and it seems that alot of people have this problem and the only solution that has worked is to change out the front o2 sensors.

Ive already cleaned out all the injectors and replaced spark plugs, and a bunch of other stuff...so I'm going to try the o2 sensors now.

I called Ford and asked how much they were and their $110 each...On americanmuscle, they have some NTK sensors for $49.99 each.

Has anyone used these NTK sensors? I'm guessing the factory ones are my best bet, but their twice as much. If the nxt's work I'd rather buy those.
 

·
Registered
Joined
·
51 Posts
i've had good results from aftermarket sensors. ntk is an oem supplier so they should give no problems at all. one thing to check is if they are plug in or universal. you can save a few more $$$ with universal but they're a little more involved (splicing wires) to install. no big deal though. hope this helps. good luck
 

·
Registered
Joined
·
6,335 Posts
^^^ yup get Bosch for like 51 bucks at advance auto after tax. Bosch is a reliable brand that's been around a while. That's wat I did with my downstream o2s no more SES lights.
But bro $110 that's ****in reducilous.
 

·
Registered
Joined
·
753 Posts
Discussion Starter · #10 ·
yea ford wants $110 for stock sensors...definitely not doin that.

I'll probably get some from autozone or americanmuscle or w/e for $50.

I just wanted to make sure they would work good, but it seems that they do!

Thanks :)
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top