Modded Mustang Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
1,446 Posts
Discussion Starter · #1 ·
trans mounts?

when I'm backing up, and let off the clutch,,then get on the clutch,,,etc... I hear/feel a decent clunk when let off the clutch. Is this the tranny mounts needing to be replaced?

I don't hear or feel anything in the forward gears. Though the trans will *thud* if I go for first gear quickly. If I granny it in, it doesn't do it.


....building my weekend repair list :)
 

·
April 2012 ROTM
Joined
·
4,739 Posts
I have the same problem...I wanna guess tranny mount...my mount is as sloppy/loose as a 10 cent ho lol
 

·
April 2012 ROTM
Joined
·
4,739 Posts
would it be ok to mix poly motor mounts with a solid tranny mount?
 

·
Registered
Joined
·
1,446 Posts
Discussion Starter · #6 ·
Cool,,,how many are there?

My u-joints had no slop in them when I lifted the car last weekend,,all solid.

..it wouldn't be anything with the clutch would it?,,something sticking?
 

·
2009 ROTY
Joined
·
5,646 Posts
can't always just see the slop in a u-joint though. mine had a similar sound, and i jacked it up and they seemed fine. untill i took out the little u-joint clips and the caps just fell out because the ends of the driveshaft had worn out and were letting the ujoint slop around.

as far as mounts, two motor mounts and 1 tranny mount. ujoints, there are 2.

don't think its anything clutch honestly...
 

·
April 2012 ROTM
Joined
·
4,739 Posts
no its not clutch related...They make poly mounts for the 3650 but there is no way im droppin that kind of money on one! lol
 

·
Registered
Joined
·
1,446 Posts
Discussion Starter · #9 ·
cool - i'm hoping the clutch will hold out a little while,,till the mods break it :)

true,,,I might as well just replace both them,,they're pretty cheap.

where would find the trans mount at? r.a. doesn't seem to have them -----edit,,,i c a.z. carries them :)
 

·
Registered
Joined
·
6,038 Posts
Sounds like the typical RWD car tranmission noise honestly... To be honest, I've never heard a stock new edge (without a built transmisison) that their tranmission didn't make noise.
 

·
Registered
Joined
·
107 Posts
mine didnt make noise untill i missed 3rd hard still shifts fine, but it make all kinds of noises now :D tko install this winter
 

·
Registered
Joined
·
1,446 Posts
Discussion Starter · #13 ·
I'm likely taking her to my local dealership sometime soon. Not necessarily for this, but for a 'reverse lockout' problem I'm having (i have another thread going about).

Have a 90 day warranty I plan on taking advantage of.
 
1 - 13 of 13 Posts
Top