Modded Mustang Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #1
When i go to shift and pull in the clutch the rpms will hang up or sometimes rise by 200 rpms or so. and when u rev it at stop, the rpms will drop all the way to 1500, and then they take forever to get back down to the idle speed. what should i do to fix this?
 

·
Banned
Joined
·
11,614 Posts
do you have ur timing advanced? mine didnt do that till i advanced it, same with my 94 i had
 

·
Registered
Joined
·
74 Posts
Discussion Starter #3
the timing is set at 10.
 

·
Banned
Joined
·
11,614 Posts
tps dirty? how much you pick your gts up for? wana trade:D
 

·
Registered
Joined
·
74 Posts
Discussion Starter #5
tps was cleaned about two weeks ago. and i got it for 3950 with 125000 miles.
 

·
Registered
Joined
·
825 Posts
Glad I'm not the only person with this problem.

Got the same trouble with mine right now. Mine will also idle around 1100 rpm when it acts up on me. If I were to shift at 3000rpm it will stay there for a few seconds. I have to wait till they come down then I shift gears. It's really annoying and I hate it. I have no idea what the problem could be either. I checked the gas pedal linkage and it snaps back on the throttle part. So it's not that. I hate EFI. that's why i'm going carbed. Get rid of the EFI.

It doesn't do this all the time. Probably a few time a week though. If I continue to drive it for lets say a half hour it will quit doing that and run normal. Idle around 550rpm and when I shift at 3000rpm push the clutch the rpm's drop fast like it should.
 

·
Registered
Joined
·
371 Posts
if you push your clutch to the floor and it doesnt disengauge as fast as it used to id say its somehting with the clutch kit, "cable, shift fork, something" im no expert of course but ive messed with my trans alot since ive had this stang... someone else will correct me if im wrong
 

·
Registered
Joined
·
4,781 Posts
sticking IAC? Maybe a small vacuum leak.

A temporary fix for electronic gremlins like these is to switch the key off and on very quickly while the car is running. This will reset the computer and should bring the idle back to normal if it is a computer glitch.
 

·
Registered
Joined
·
685 Posts
Iac is what my problem was I just cleaned the crap out of it and it cured the prob for me
 
1 - 11 of 11 Posts
Top