Modded Mustang Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
245 Posts
Discussion Starter #1
Just did a major upgrade job now car wont run right. The car is a 88 with Speed dens. Upgrades are: uncatted h-pipe, ford racing shorty headers P specific. GT40p heads, Crane 1.7 roller rockers, explorer upper and lower intake, BBK 65mm TB. When I fired it up it ran really rough and wouldnt go above 3000 rpm. Sprayed carb cleaner with no real change. The only thing I noticed wrong was some coolant was leaking into the TB from the egr spacer. all other gaskets looked ok. Any suggestions?

Also anybody know were to buy new water pump bolts?
 

·
Registered
Joined
·
245 Posts
Discussion Starter #3
been told that that as long as the cam isnt changed i should be ok. but at this point i would agree
 

·
Banned
Joined
·
11,614 Posts
the 1.7 roller rockers gave you more lift outa the stock cam though, maybe thats enough to piss it off?
 

·
Registered
Joined
·
423 Posts
the 1.7 roller rockers gave you more lift outa the stock cam though, maybe thats enough to piss it off?
thats what i was thinking
 

·
Registered
Joined
·
149 Posts
speed density will work aslong as no cam lift or duration is changed. even wen ur crusing with the car it will break up alittle bit. full throttle will be ok. i would check timing fuel pressure, tps vaccum leaks.
 

·
Registered
Joined
·
245 Posts
Discussion Starter #11
i was hopeing it wasnt the rockers. i had the fuel pres. regulator hooked directly to the vac tree. it looked like all the gaskets were good. i'm going to spin the engine back to tdc to dubble check i had the distributer in right and not 180 out. thanks.
 

·
Atomized
Joined
·
1,397 Posts
i have a friend that has 1.6 rollers on a b cam with speed density and his car doesn't hold an idle well but it runs great. I dont think rollers are the problem.
 

·
Who Care's ... Boost It!
Joined
·
538 Posts
Make sure you have EVERYTHING properly hooked back up.
 

·
Registered
Joined
·
245 Posts
Discussion Starter #15 (Edited)
just pulled the plugs.... they were badly fouled. maybee that will help. the tps was hooked up. i used 2 diffrent ones. the firing order was good (didnt trust myself so i had 2 people check). as far as hooking everything back up, it wasnt a direct change over. the old intake and new intake didnt have all the same connections. based on the info i had i thought i got it all.
thanks again
 

·
Registered
Joined
·
401 Posts
defitenitely not the roller rockers 1.7 on stock cam will be fine with speed density you did say the plugs were fouled were they new to begin with??
 

·
Registered
Joined
·
4,356 Posts
if nothing you try works then the only thing i could recommend is to put the stock parts back on and install one at a time and run the car, when you notice the problem again , that is your source....
 

·
Registered
Joined
·
370 Posts
get rid of that speed density get MAF
 

·
PSN alphadong11
Joined
·
28,936 Posts
did you have the number 1 piston at tdc and then check the rotor tip and see if it is pointing to the number 1 cylinder
 
1 - 20 of 21 Posts
Top